0

I've setup a Xp1 Installation on Windows Server 2012R2 (Infrastructure you can find here)

Everthing works fine so far only the Xconnect is not working right. I've a dedicated Server where xConnect is installed, so its not installed on my cm or cd Server.

On the Dashboard you can see only a generic error message

enter image description here

in the Logfiles I get the following error

    3208 15:24:00 INFO  Cache created: 'ExperienceAnalytics.DimensionItems' (max size: 2MB, running total: 3297MB)
    4512 15:24:00 ERROR [Experience Analytics]: System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: Eine vorhandene Verbindung wurde vom Remotehost geschlossen. ---> System.Net.Sockets.SocketException: Eine vorhandene Verbindung wurde vom Remotehost geschlossen
    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
    --- End of inner exception stack trace ---
    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
    at System.Net.FixedSizeReader.ReadPacket(Byte[] buffer, Int32 offset, Int32 count)
    at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
    at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
    at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
    at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
    at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
    at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
    at System.Net.ConnectStream.WriteHeaders(Boolean async)
    --- End of inner exception stack trace ---
    at System.Net.HttpWebRequest.GetResponse()
    at Sitecore.Xdb.Reporting.Datasources.Remote.RemoteReportDataSourceProxy.GetData(ReportDataQuery query)
    at Sitecore.Xdb.Reporting.ReportDataProvider.ExecuteQueryWithCache(ReportDataQuery query, ReportDataSource dataSource, CachingPolicy cachingPolicy)
    at Sitecore.Xdb.Reporting.ReportDataProvider.GetData(String dataSourceName, ReportDataQuery query, CachingPolicy cachingPolicy)
    at Sitecore.ExperienceAnalytics.Api.ReportDataService.ExecuteQuery(IReportQueryData queryData, CachingPolicy cachingPolicy)
    at Sitecore.ExperienceAnalytics.Api.ReportingService.RunQuery(ReportQuery reportQuery)
    at Sitecore.ExperienceAnalytics.Api.Http.AnalyticsDataController.Get(ReportQuery reportQuery)

the following Certificates are installes on my cm, cd and xconnect Server they are all Ca Certified by our internal root Ca

enter image description here

In my IIS on my xconnect all https connetion are set right I think.

enter image description here

and every IIS AppPool on cm and xconnect has access to the certificates

the Thumbprint from the xConnectCert you can find in the connectionstrings on the cm server for the xconnect sites

Both Certificates are trusted certificates

enter image description here

I've also tried to search in wireshark, but I don't know where I have to look for or how I can see if its not working right

enter image description here

I've also read this post https://kamsar.net/index.php/2017/10/All-about-xConnect-Security/ and I think I can't find any mistakes on my site.

I've also tried this Stackexchange Article and added the Registry key like descriped in the Article: https://stackoverflow.com/questions/26247462/http-error-403-16-client-certificate-trust-issue and its still the same problem.

  • I can open each of my xconnect sites on the xconnect Server and every site shows the time

enter image description here

when someone needs some more Informations please tell me what else to post.

  • Can you open the browser with xconnect site locally on that machine? Is it showing you current time? Have you configured certificate thumbprint correctly? – Peter Procházka Jul 20 '18 at 11:35
  • Try to comment out "validateCertificateThumbprint" configuration setting in path_to_your_xconnect_site/App_config/AppSettings.config and try again. This will at least eliminate problem with thumbprint – Peter Procházka Jul 20 '18 at 11:37
  • You have probably find it already but take a look to this very useful article -> thebitsthatbyte.com/sitecore-9-xp1-client-certificates-guide – Peter Procházka Jul 20 '18 at 11:39
  • to comment out the "validateCertificateThumbprint" did not work, it stays the same problem and the article I've read allready and I think thats all fine here. – squadwuschel Jul 20 '18 at 11:54
1

Experience Analytics API is hosted on the Sitecore Reporting Server, which is outside of XConnect. Depending on how your configuration, this could be either the same server as CM or a dedicated one. I'd skip XConnect connection troubleshooting and looked into whether you have a remote reporting server configured. I believe the following article could help: https://doc.sitecore.net/developers/server-role-configuration-reference/core-roles/reporting-service/index.html

  • my reporting Server is installed on my cm machine and I've used the XP1 Installation package for SIF. I will have a look at my configurations like descriped in your link thx – squadwuschel Jul 21 '18 at 8:14
  • Yes the Rporting Server was the Problem it was not running :-/ the Problem was that the ssl certificate was not set but SNI was acitivated. So you couldn't call it, after I've fixed this everything was working fine – squadwuschel Aug 17 '18 at 5:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.