0

I am working on a new site in our Dev environment and I can not get the Password Recovery working. We have it working for another site in a different box.

So I first thought it was a communication issue. However, from that box I am able to send email via telenet.

I have looked at the web.config settings:

<passwordRecovery argsType="Sitecore.Pipelines.PasswordRecovery.PasswordRecoveryArgs">
    <processor mode="on" type="Sitecore.Pipelines.PasswordRecovery.VerifyUsername, Sitecore.Kernel" />
    <processor mode="on" type="Sitecore.Pipelines.PasswordRecovery.GeneratePassword, Sitecore.Kernel" />
    <processor mode="on" type="Sitecore.Pipelines.PasswordRecovery.PopulateMail, Sitecore.Kernel" />
    <processor mode="on" type="Sitecore.Pipelines.PasswordRecovery.SendPasswordRecoveryMail, Sitecore.Kernel" />
</passwordRecovery>

<setting name="Login.DisablePasswordRecovery" value="false" />

<setting name="MailServer" value="smtp.cantTellYou.com" />

Other things I looked at:

  • The app pool user is a local admin on the box
  • The core database has the same password recovery settings as the working site

Is there a log or something I can look at to debug if these messages are getting sent out?

2
  • Anything in the logs like it getting denied by the mail server?
    – Chris Auer
    Aug 28 '18 at 0:49
  • nothing in the logs The issue was a patch override file
    – Mike
    Aug 28 '18 at 11:40
2

I believe that you could troubleshoot this by opening log file under Data\logs folder.

In order to fix your issues, follow below two steps.

1) If your SMTP server requires authentication, you need to also configure these settings in Web.config as configuring just MailServer is not sufficient:

  • MailServerUserName
  • MailServerPassword
  • MailServerPost

You can do that by opening Web.config and changing these elements:

<!-- MAIL SERVER USER If the SMTP server requires login, enter the user name in this setting-->
<setting name="MailServerUserName" value="" />
<!-- MAIL SERVER PASSWORD If the SMTP server requires login, enter the password in this setting-->
<setting name="MailServerPassword" value="" />
<!-- MAIL SERVER PORT If the SMTP server requires a custom port number, enter the value in this setting. The default value is: 25-->
<setting name="MailServerPort" value="25" />

2) You also need to change the sender of the Forgot your Password email to a valid email address. You can change the subject and content of the email if you wish. To do this, follow these steps:

  1. Log in to Sitecore as an administrator

  2. In the Launchpad, open the Desktop, and select the Core database.

  3. In the Content Editor, navigate to /sitecore/system/Settings/Security/Password recovery/Password Recovery Email.

  4. Enter a valid email address in the Sender email address field, and change the other fields as you need.

More information can be found in official documentation: https://doc.sitecore.net/sitecore_experience_platform/80/setting_up_and_maintaining/security_and_administration/login/configure_the_password_policy#_Enable_the_forgotten

2
  • Thank you I have looked at all that. The functionally works on my local but Dev so I am still leaning toward permission issue but again the user can send out emails over telnet
    – Mike
    Jul 30 '18 at 16:11
  • On localdev, do you use smtp4dev or similar tool or you are really sending email with same settings as on the other environment? Jul 30 '18 at 16:22
0

So the issue was with the MailServer variable indeed. The part that was causing the confusion was there was a patch override file setup in production. Using showconfig.aspx helped identify the root cause.

Funny story, even after updating the patch override file the mail server still did not work, what had happened is someone made a backup of the config file and named it zzz_CompanySettings_Old.config which had the original values and would always run after zzz_CompanySettings.config

Removing the _Old file and setting the patch override correctly fix the issue.

1
  • Hi @Mike can you please accept your answer as the solution! Sep 11 '19 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.