0

I'm trying to setup a A/B page test in Sitecore 8.2 Update 5 and when I start the test, I see the below error message and the page blows up.

Exception: System.InvalidOper1tionException
Message: Test combination does not match the test definition
Source: Sitecore.ContentTesting
   at Sitecore.ContentTesting.Models.TestCombination.GetValue(Int32 variableIndex)
   at Sitecore.ContentTesting.Pipelines.EvaluateTestExposureBase`1.ValidateCombinationDatasource(TestCombination combination, ITestConfiguration testConfiguration)
   at Sitecore.ContentTesting.Pipelines.EvaluateTestExposureBase`1.Process(TPipelineArgs args)
   at (Object , Object[] )
   at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
   at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain)
   at Sitecore.Mvc.Pipelines.PipelineService.RunPipeline[TArgs](String pipelineName, TArgs args)
   at Sitecore.Mvc.Routing.RouteHttpHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Have anyone faced this issue in the past? Any ideas or thoughts?

0

I contacted Sitecore support and the issue is when the A/B test is not fully published from CM to CD servers. They provided a patch which resolved the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.