2

I have tried installing Sitecore 9 with and also without SIFLESS but I am getting below error:

** Handler "AutowiredPageHandlerFactory" has a bad module "ManagedPipelineHandler" in its module list **

Error Message

Frameworks / Versions - Sitecore 9.0.2, DB - SQL 2016, Solr - 6.6.2 ( with https )

10
  • did you install URL Rewrite 2.1? Aug 7 '18 at 11:06
  • Yes installed URL Rewrite
    – Vamshi
    Aug 7 '18 at 11:08
  • Have you installed Web Deploy 3.6 for Hosting Servers? Aug 7 '18 at 11:10
  • Nope I haven't installed it. Just installed Web Deploy 3.5 / 3.6 as I am installing in a dev laptop. Do I need 3.6 for hosting servers as well?
    – Vamshi
    Aug 7 '18 at 11:11
  • 1
    Got it.. Thanks @PeterProchazka. I enabled windows features as mentioned in your blog and started the installation again just now. Will let you know once it's done.
    – Vamshi
    Aug 7 '18 at 11:19
1

You need to install these prerequisites before installing Sitecore 9 through Web Platform Installer (WPI).

Install these features through WPI:

  • Web Deploy 3.6 for Hosting Servers
  • URL Rewrite 2.1

Instructions:

Download and run WPI: https://www.microsoft.com/web/downloads/platform.aspx

In Programs section search for "Web Deploy" and choose "Web Deploy 3.6 for Hosting Servers" from search results. Click "Add" button.

In Programs section search for "URL Rewrite" and choose "URL Rewrite 2.1". Click "Add" button.

Click "Install" in the button of the screen and "I Accept" in license window.

As a side effect of installing these features is installation of over 50 prerequisite features. And you can guess that one of them is also IIS ;)

More detailed prerequisities can be found in my blog post -> http://tothecore.sk/2018/02/04/installing-sitecore-9-0-1-part-1-3-preparing-virtual-machine .

3

We faced the similar error while installing Sitecore 9 Update 2, because I was configuring on the new machine with first time .Net/Sitecore installation. The problem was due to missing ASP component (ASP, ASP.net 3.5 and ASP.net 4.7) Go to > Control Panel\Programs\Programs and Features Click > Turn Window Features on or off Navigate To > Internet Information Services > World Wide Web Services > Application development features

ASP

Asp.net 3.5

Asp.net 4.7

And make sure, all three above option should be checked, if not checked it and click ok. Hope, it will resolve the issue.

1
  • Classic ASP? Really?
    – Mark Good
    Nov 7 '18 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.