1

I am trying to install Sitecore 9.0 Update-2 on Azure PaaS using MarketPlace but I am getting the below error during deployment:

enter image description here

{"code":"c","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.","details":[{"code":"Conflict","message":"{\r\n \"status\": \"Failed\",\r\n \"error\": {\r\n \"code\": \"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"DeploymentFailed\",\r\n \"message\": \"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.\",\r\n \"details\": [\r\n {\r\n \"code\": \"Conflict\",\r\n \"message\": \"{\r\n \\"status\\": \\"Failed\\",\r\n \\"error\\": {\r\n \\"code\\": \\"ResourceDeploymentFailure\\",\r\n \\"message\\": \\"The resource operation completed with terminal provisioning state 'Failed'.\\",\r\n \\"details\\": [\r\n {\r\n \\"code\\": \\"PasswordNotComplex\\",\r\n \\"message\\": \\"Password validation failed. The password does not meet policy requirements because it is not complex enough.\\"\r\n }\r\n ]\r\n }\r\n}\"\r\n }\r\n ]\r\n }\r\n ]\r\n }\r\n}"}]}

When I dig into the exception, I got to know this is because of "The password does not meet policy requirements because it is not complex enough"

I am not using the complex password, also at the time of filling the parameters, it didn't show me the strong password validation error,

enter image description here

There are three password parameters during the installation as below:

  1. Sitecore Admin Password
  2. SQL server password
  3. certification password

I am not sure, which password policy is violating during the deployment, as it's not throwing the validation error individually.

But, once I provided the complex password, then it worked for me.

0