0

I faced a very weird situation. I got a heritage with Sitecore 8.0 web site with analytics enabled. Everything works OK. But now I got a task to enable personalization for some components.

I studied manuals and tried to implement a simple rule:

enter image description here

I edited this component either from Experience Editor or from Presentation -> details -> Controls..

At the layouts I can see that there are two rules:

enter image description here

But after saving and publishing, when I open this page, I can't see any effect.

In the Internet there is no articles with a similar problem, so I absolutely don't know what to do.

Sincerely, Dmitry

6
  • Anything in the logs for this. I have had several personalization issues and it almost always analytics code throwing errors.
    – Chris Auer
    Aug 15 '18 at 14:00
  • Is setting <setting name="Xdb.Enabled" value="true" />? (on your CD servers)
    – Mark Cassidy
    Aug 15 '18 at 15:38
  • Yes, XDB.Enabled = true. Without this option I couldn't even create a rule. Checked Sitecore logs. Only informational messages.
    – Dmitry T
    Aug 16 '18 at 7:25
  • I created a test page based on default "Sample item" template. On this page everything works OK. So, the issue with my templates. Any ideas what it can be? Because developers say that there is nothing special and they used only standard Sitecore features.
    – Dmitry T
    Aug 16 '18 at 8:06
  • 1
    <setting name="Xdb.Enabled" value="true" /> as @MarkCassidy mentioned.... or in Sitecore 8.1 up, the key thing is <setting name="Xdb.Tracking.Enabled " value="true" /> for personalization. Sep 17 '18 at 3:37
1

Sometimes this is due to component-level caching. If the component, or any of the 'parent components' (components it sits inside thanks to placeholders) have caching enabled, the personalization won't be executed and it will just load from the cache.

Ensure that all caching is disabled so that you can be sure the personalization is getting executed.

(This may not be the actual issue, but is one possible issue)

1
  • Caching is disabled for all templates. To check IIS cache i tried to restart web server after publishing..
    – Dmitry T
    Aug 15 '18 at 13:37
1

This issue comes when you are running sitecore in standalone mode(CM and CD both are the same). After making these below entries check your sitedefination.config( or sitecore config) and make sure enableTracking should be true Xdb.Enabled value="true", Xdb.Tracking.Enabled " value="true"

0

In your screenshot there is nothing set on the personalize content.

To test that personalization works on your site I would create two simple rules, is it Sunday and point to one personalize content and do the same for another day. Play around with those simple rules. I would recommend to test these out in explore mode.

Sitecore.net explore mode

If you have a client that doesn't have xdb in their license, than xDB would be deactivated. You could check the logs to verify that xdb is enabled on site startup.

1
  • Well....he sort of does.... the personalized version should Hide the component. This should be enough to see the difference with personalization. (shown when not in August, hidden when in August). Note to @Dimity T....it's now September....is THAT why you don't see the component hidden? :-) Sep 17 '18 at 3:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.