5

I'm using Sitecore 8.2 update 5 and just setup a MongoDB using SSL, and it works fine but when Sitecore tries to communicate with it, does not work at all.

In my ConnectionStrings.config, I've set as follows

mongodb://mongodb.mydomain.com/analytics?ssl=true

And Sitecore throws an error saying Tracking.Current is not initialized, however, if I remove SSL from MongoDB and the ?ssl=true parameter everything works fine.

Any idea how to properly establish the communication?

5
  • 1
    Have you tried looking at the following article: firebreaksice.com/configure-sitecores-mongo-client-use-ssl Aug 21, 2018 at 18:11
  • Yes, I did but it throws an error saying "Could not load file or assembly 'MongoDB.Driver, Version=1.10.0.62", and the MongoDB.Driver.dll is 2.4.4.0 originally. I tried to change it but didn't work either due other dependencies. Aug 21, 2018 at 18:27
  • 1
    When do you see this error @ViniciusDeschamps? Would mind sharing the code customization you did to read the SSL settings? Aug 21, 2018 at 18:45
  • Sorry, I didn't perform that, I got confused with the followin article getfishtank.ca/en/blog/… Aug 21, 2018 at 18:54
  • It worked like a charm after I put some attention on the information you and @HishaamNamooya provided Aug 21, 2018 at 20:04

1 Answer 1

5

OOTB Sitecore does not communicate with Mongo using SSL, we need to implement a custom pipeline for such communication.

Customize the Sitecore.Analytics.MongoDB.Config by defining a new Pipeline.

Now you have two approaches to establish SSL connection between Mongo and Sitecore.

  1. SSL Integration using physical PFX file

  2. SSL Integration reading Machine Key

Please have a look at my blog post for more details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.