1

I do no see the Catalog Management(sitecore > Commerce > Catalog Management) showing up any data. This is after done with the setup of Habitat Home commerce on Sitecore commerce 9 update 2. All the templates related to commerce and Catalogs are present and Update Data Templates work without any errors. I do not see any errors in the logs.

What I need to do so that I can fetch it?

enter image description here

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • were you able to find a solution for this? – Rama Krshna Ila Sep 20 '18 at 4:03
  • The only option I found out is re-installation. No idea yet on how to fix it. steps tried to make it work without re-installation are 'update data templates' and 'refresh commerce cache', re-publish, re-index etc – Amitabh Sep 20 '18 at 7:29
0

You can check your Store-frontend settings, under: /sitecore/Commerce/Commerce Control Panel/Storefront Settings/Storefronts/Storefront/Catalog Configuration

Storefrontend configuration

if you navigate there you will find the catalog: Catalog As you can see "Habitat Master" is set as the selected Catalog there.

furthermore you can run the sql query on the Sharedenvironment:

SELECT TOP (1000) [Id]
  ,[EnvironmentId]
  ,[Version]
  ,[Entity]
  ,[EntityVersion]
  ,[Published]

FROM [SitecoreCommerce9_SharedEnvironments].[dbo].[CatalogEntities] where id like '%Habitat%Master'

if you check the entity you will see the parrent id of the catalog in sitecore: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.