2

I'm trying to connect to my single-instance of Sitecore hosted on Azure using Visual Studio 2015 (with the Sitecore Rocks plugin). I get this error message saying 'Welcome to Sitecore, do you want to retry?'

I'm trying to resolve the issue using the idea here.

It advises the reader to make a change to web.config to connect to Sitecore. But now I think I have a circular problem here - I can't connect VS to Sitecore without modifying web.config, and I can't modify web.config without connecting VS to Sitecore. Could someone please advise me what I'm missing here? I'm sure I'm not the first one to connect VS 2015 to Sitecore Azure! Or is it possible to modify web.config without Visual Studio?

Any help with the above would be greatly appreciated!

Joonu

PS - I'm new to Sitecore! :-)

4
  • You need to modify the web.config file directly in the website root folder. You shouldn't need to go through Visual Studio for that. Just open up the web.config file in Notepad++ or other text editor and make the changes.
    – Richard Seal
    Aug 27 '18 at 17:11
  • My instance is on Azure, not on a local disk, how do I access the web.config file and then edit and put it back up there?
    – joonu75
    Aug 27 '18 at 17:14
  • Welcome Joonu! You can also directly edit files through the Azure portal. Here's a question that might help: stackoverflow.com/questions/40231895/… In general, you would want to setup a proper deployment flow and not manually edit the files Aug 28 '18 at 14:19
  • Please refer my answer below for your Sitecore Rocks issue. To access your files on azure, you can go to portal.azure.com, then to your subscription, then corresponding app service and kudu. Another way is to connect to the required app service via vpn clients such as Filezilla. Aug 28 '18 at 17:56
1

If you are using IaaS and a virtual machine, you should be able to connect to your VM instance with RDP and modify the web.config from there.

If you are using PaaS and an Azure App Service, you can set up an FTP user, or simply get the FTP user and password from your publish profile. Then you can use something like Filezilla to edit the web.config.

2
  • Thanks, I followed your pointer, FTPed to the PaaS setup and did what I wanted to. Though it would have been great if Sitecore themselves had provided a way to get this done through the console! :-)
    – joonu75
    Aug 30 '18 at 19:04
  • Yeah, I'm hoping with Sitecore 9 on Azure, we can use Azure App settings for certain things. docs.microsoft.com/en-us/azure/app-service/… Sep 6 '18 at 21:05
0

Add the below to your web.config file in web root and try the Sitecore Rocks connection again. It will work.

<location path="sitecore/shell/WebService">
<system.web>
    <authorization>
        <allow users="?,*" />
    </authorization>
</system.web>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.