5

One of our developers is getting this error randomly when perusing through his local development instance in Sitecore 8.1 Update 3 using Chrome. I am not getting the exception at all on my machine on any of the browsers. Is there an known issue with Chrome on certain machines and what may be the cause of this. Seems when he closes browser or shuts down system it seems to alleviate problem.

enter image description here

  • One question. Does he use Sitecore Extensions for google chrome? I guess it might be my fault if the answer is yes. – Alan Płócieniak Oct 14 '16 at 14:22
  • Is he using tooling like fiddler? Could it be that his security settings for chrome are set up to high or perhaps clear all his cached data and try to reproduce, the moment it occurs, let me know what the sitecore log says – Dilyano Senders Oct 14 '16 at 14:49
  • Alan he does not use Sitecore Extensions with Google Chrome. – Toby Gutierrez Oct 14 '16 at 15:14
  • Dilyano, he does not using tooling like Fiddler. – Toby Gutierrez Oct 14 '16 at 15:15
  • Is his app pool running under Network Service? – Ben Golden Oct 14 '16 at 17:30
3

If this is really only happening in Chrome, I would suspect an extension. Something must be messing with either the CSRF cookie value or the CSRF hidden form field value. Try it in an incognito window or with extensions disabled. If the problem goes away, find the bad module via process of elimination.

If this can be reproduced in other browsers (most likely by restarting the app pool while using the Sitecore client), then it is likely due to a lack of access to the HKEY_CURRENT_USER registry. This is where ASP.NET stores the auto-generated machine key. If it can't store the key, then it will regenerate it each time the app pool restarts and the app won't be able to decrypt token in the hidden CSRF field.

Theoretically, you shouldn't see this machine key issue in recent versions of Windows unless you are running the app pool under a custom user account. On a developer machine, you should just go with Network Service and set Load User Profile to true. Otherwise, you could set a static machine key in the web.config file.

Here are some resourses with more info:

  • 1
    Thanks for all the advice Ben. We are looking into on our end. As well as just using Firefox for Sitecore development as a Sitecore practice. Seems to be humming along with Sitecore 8+ development. – Toby Gutierrez Oct 17 '16 at 14:20
3

We found that by using an Incognito window in Google Chrome or using Private Browsing Mode in Firefox that this error will go away and we can continue work in Sitecore. Hope this helps others with this issue in the future.

  • 2
    If Incognito avoids the problem, then it is probably an extension that is really at fault – Ben Golden Oct 19 '16 at 14:39
  • If I open in the incognito window it has worked, but how to fix this issue to open it in normal browser..? – Sudheer Suggu Jul 24 '18 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.