I've setup a Sitecore 9.0.2 solution, and i'm testing out JSS. I'm using code-first, and I'm trying to get FullWipe to work on jss deploys.

According the documentation, i'm supposed to set SitecoreJss.WipeAllowed = true, and set wipeOnImport = true.

These settings are from my showconfig.aspx:

<setting name="SitecoreJSS.WipeAllowed" value="true" patch:source="Sitecore.JavaScriptServices.Configuration.config"/>

<app name="customer" sitecorePath="/sitecore/content/jss-home" useLanguageSpecificLayout="true" graphQLEndpoint="/api/customer" inherits="defaults" wipeOnImport="true" patch:source="customer.deploysecret.config" deploymentSecret="..." debugSecurity="false"/>

I was expecting it to delete the previously added app items in Sitecore (or put in recycle bin) on each deploy, but it is not doing so. It simply just appends templates and fields on templates.

Im doing: jss deploy app -c -d to deploy my app.

Can anyone tell me what I'm doing wrong here?

up vote 4 down vote accepted

UPDATE

The documentation for full wipe mode has been updated to reflect TP4 usage: https://jss.sitecore.net/docs/fundamentals/dev-workflows/code-first#import-full-wipe-mode


It looks like the documentation around wipe is out of date. With TP4, you need to set the SitecoreJSS.WipeAllowed config setting to true (as you already have):

<setting name="SitecoreJSS.WipeAllowed" value="true" />

But instead of adding the wipeOnImport="true" attribute to your app config, you pass the --wipe parameter via JSS CLI deploy command.

jss deploy app -c -d --wipe

or use the -w alias for --wipe

jss deploy app -c -d -w

We'll get the documentation updated as soon as possible.

  • 1
    Worth noting as well in TP4+ that the WipeAllowed global setting defaults to true for Sitecore installs that are in the Standalone role. This is designed to make it easy to wipe while developing, but hard to mistakenly wipe a production site (which would have a ContentManagement role) – Kam Figy Sep 6 at 16:16
  • 1
    Tested and works beautifully :) – user2689286 Sep 7 at 7:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.