I'm working with Sitecore 9.0.2 and Solr 6.6.2.

When i tried to rebuild xDB search index, i saw some error in log of SOLR as below :

9/7/2018, 4:47:39 PM
ERROR false
org.apache.solr.common.SolrException: Exception writing document id 873f5ab98eae06000000055b8a091a00 to the index; possible analysis error: Document contains at least one immense term in field="text_s" 
(whose UTF8 encoding is longer than the max length 32766),​ all of which were skipped. Please correct the analyzer to not produce such terms.

The prefix of the first immense term is: '[40,​ 115,​ 117,​ 98,​ 109,​ 105,​ 116,​ 32,​ 101,​ 110,​ 113,​ 117,​ 105,​ 114,​ 121,​ 41,​ 32,​ 109,​ 101,​ 115,​ 115,​ 97,​ 103,​ 101,​ 58,​ 32,​ 100,​ 105,​ 114,​ 101]...',​ 
original message: bytes can be at most 32766 in length; got 92665.

Perhaps the document has an indexed string field (solr.StrField) which is too large

Anyone to know how to fix it ?

1 Answer 1


You will need to go custom on that one. Check this answer on some of your options to avoid Solr rejecting to index the field.

You also want to check the indexer logs to make sure you are trying to solve the right issue. I say this because that field doesn’t look like a XConnect field.

  • I only saw an unclear error in the indexer log : 2018-09-10 17:48:18.563 +07:00 [Error] An error occured. System.Net.Http.HttpRequestException: Response status code does not indicate success: 400 (Bad Request) :((
    – Duan Le
    Sep 10, 2018 at 11:07
  • @DuanLe that makes it quite likely the same error. If you want to be extra sure, you can stop the indexer Windows Service and run it from the command line instead while running fiddler i.e. you can see the actual error Solr returns if the details are not making it to the log.
    – eglasius
    Sep 10, 2018 at 11:14
  • sorry but how rebuild xdb search index process can run if you can stop Indexer Windows Service. I tried stop it and run 'XConnectSearchIndexer -rr' in CMD but it didn't work
    – Duan Le
    Sep 10, 2018 at 12:07
  • That registers the rebuild request. If you run it again without the -rr, it will run the indexer in console mode and will start running the rebuild as well. The idea is to make sure to run the indexer in a way you can capture the traffic through fiddler (because it is problematic when running as a service).
    – eglasius
    Sep 10, 2018 at 14:28
  • 1
    Thanks! I followed the link that you provide and the issue was fixed
    – Duan Le
    Sep 11, 2018 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.