1

I have recently upgraded web site from Sitecore 8.2 to 8.2 update 7. I have enabled the sitecore xDB in sitecore.xDB.config. Now when i am browsing the web site, i am getting the following error.

Could not get pipeline InitializeMongoDbCollectionIndexes(domain:)

enter image description here

I have already tried issue Cannot patch Sitecore initialize pipeline (Sitecore 8.1 Update 3) but it does solve in my case.

  • Are you getting this issue in dev, test or production environment? initializeMongoDbCollectionsIndexes is a new pipeline added in SC8.2 update 7 (link for release notes: dev.sitecore.net/Downloads/Sitecore%20Experience%20Platform/82/…) Can you check your configuration to see that it is pointing to the right pipeline and check that you're solution is building/deploying against the right version of Sitecore. – Jarmo Jarvi Sep 12 '18 at 22:20
2

I encountered similar error when i upgraded to update 7 and enabled xDB in configuration. Please make sure you have the following configuration in pipelines section of Sitecore.Analytics.Mongodb.config(in app_config/include).

<initializeMongoDbCollectionsIndexes>
    <processor type="Sitecore.Analytics.Pipelines.InitializeMongoDbCollectionsIndexes.EnsureMongoDbCollectionsIndexesProcessor, Sitecore.Analytics.MongoDb" />
    <processor type="Sitecore.Analytics.Pipelines.InitializeMongoDbCollectionsIndexes.EnsureMongoDbInteractionCollectionIndexForGetAllHistoricalInteractionsProcessor, Sitecore.Analytics.MongoDb" />
  </initializeMongoDbCollectionsIndexes>
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.