0

I have disabled the Asset Optimization for the entire SXA site. I am able to view the updated styles of my Theme in normal mode. But, in editing mode, not able to get the updated styles. Is there any setting or querystring I can append to url to resolve this. I tried clearing my browser cache and using aodisabled=1 (not required as I disabled it anyway) but still no luck.

Thanks

1

You can turn off asset optimization in 3 ways:

  • /sitecore/system/Settings/Foundation/Experience Accelerator/Theming/Optimiser - under this item, you can globally turn off scripts and styles minification and bundling
  • /sitecore/content/TENANT/SITE/Presentation/Page Designs - under this item in your site, in the Asset Optimization section you can control minification and bundling for your site only
  • by adding aodisable=1 to query string you can turn off asset optimization for a request (depending on the SXA version you might need to enable XA.Foundation.Theming.AssetsOptimizationSwitch.Enabled setting in the Sitecore.XA.Foundation.Theming.config file)

I'm pretty sure that all of those options are working fine as I'm using them randomly from time to time. If you don't want to use optimization at all:

  • turn it off globally - this basically is enough
  • remove all optimize and optimize-min item from your styles and scripts folders under themes - but this is just for a sake of having a clean tree of items

If you still don't see updated styles or scripts - that is just a browser cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.