2

According to the cachetuner, I should extend my "rules" cache. (By default it is 800KB)

Does anybody now which setting in sitecore config I should adapt in order to achieve this?

1 Answer 1

6

The setting is called Rules.MaxCachedRules. The value should be in KB or MB. You can set it to 0 to disable the cache completely.

<?xml version="1.0"?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:set="http://www.sitecore.net/xmlconfig/set/">
  <sitecore>
    <settings>
      <!-- Default value if not set otherwise (800KB) -->
      <setting name="Rules.MaxCachedRules" value="2MB" />
    </settings>
  </sitecore>
</configuration>
1
  • Do you know if there is a way to disable Rule cache other than setting value to 0. This doesn't seem to work in Sitecore 9.1.1 Sep 25, 2019 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.