0

I am using Sitecore 8.2 update 3 and Azure search service in our application. I am able to rebuild the master index successfully but when i am rebuilding web index, it will get stuck in middle and never completes. I get below error in logs:

WARN Crawler : AddRecursive DoItemAdd failed - {D9B152A2-0503-45EF-ACE0-AAFE117120A7} Exception: System.AggregateException Message: One or more errors occurred. Source: mscorlib at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions) at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken) at System.Threading.Tasks.Parallel.ForWorker[TLocal](Int32 fromInclusive, Int32 toExclusive, ParallelOptions parallelOptions, Action1 body, Action2 bodyWithState, Func4 bodyWithLocal, Func1 localInit, Action1 localFinally) at System.Threading.Tasks.Parallel.ForEachWorker[TSource,TLocal](IEnumerable1 source, ParallelOptions parallelOptions, Action1 body, Action2 bodyWithState, Action3 bodyWithStateAndIndex, Func4 bodyWithStateAndLocal, Func5 bodyWithEverything, Func1 localInit, Action1 localFinally) at System.Threading.Tasks.Parallel.ForEach[TSource](IEnumerable1 source, Action1 body) at Sitecore.ContentSearch.Azure.Http.CompositeSearchService.PostDocuments(ICloudBatch batch) at Sitecore.ContentSearch.Azure.CloudSearchUpdateContext.Commit() at Sitecore.ContentSearch.CommitPolicyExecutor.IndexModified(IProviderUpdateContext context, Object document, IndexOperation operation) at Sitecore.ContentSearch.Azure.CloudSearchUpdateContext.AddDocument(Object itemToAdd, IExecutionContext[] executionContexts) at Sitecore.ContentSearch.Azure.CloudSearchIndexOperations.Add(IIndexable indexable, IProviderUpdateContext context, ProviderIndexConfiguration indexConfiguration) at Sitecore.ContentSearch.SitecoreItemCrawler.DoAdd(IProviderUpdateContext context, SitecoreIndexableItem indexable) at Sitecore.ContentSearch.HierarchicalDataCrawler1.CrawlItem(T indexable, IProviderUpdateContext context, CrawlState`1 state)

Nested Exception

Exception: Sitecore.ContentSearch.Azure.Http.Exceptions.BadRequestException Message: Error in the request URI, headers, or body Source: Sitecore.ContentSearch.Azure at Sitecore.ContentSearch.Azure.Http.SearchServiceClient.EnsureSuccessStatusCode(HttpResponseMessage response) at Sitecore.ContentSearch.Azure.Http.SearchServiceClient.UpdateIndex(IEnumerable1 fields) at Sitecore.ContentSearch.Azure.Schema.SearchServiceSchemaSynchronizer.SyncRemoteService(IEnumerable1 sourceSchema, IEnumerable1 incomingSchema) at Sitecore.ContentSearch.Azure.Schema.SearchServiceSchemaSynchronizer.<>c__DisplayClass11_0.<EnsureIsInSync>b__0() at Sitecore.ContentSearch.Azure.Utils.Retryer.RetryPolicy.Execute(Action action) at Sitecore.ContentSearch.Azure.Http.SearchService.PostDocumentsImpl(ICloudBatch batch) at Sitecore.ContentSearch.Azure.Http.SearchService.PostDocuments(ICloudBatch batch) at Sitecore.ContentSearch.Azure.Http.CompositeSearchService.<>c__DisplayClass11_0.<PostDocuments>b__0(ISearchService searchService) at System.Threading.Tasks.Parallel.<>c__DisplayClass17_01.b__1() at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask) at System.Threading.Tasks.Task.<>c__DisplayClass176_0.>b__0(Object )

Nested Exception

Exception: >Sitecore.ContentSearch.Azure.Http.Exceptions.AzureSearchServiceRESTCallException Message: {"error":{"code":"","message":"The request is invalid. Details: >index.fields[0].name : The name field is required.\r\n"}}

0

I got this exception while trying to rebuild sitecore web index. This issue arises when sitecore tries to index some item whose template or field doesn't exist in the web database.

I got this issue resolved by republishing the templates as some templates were not published properly earlier.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.