3

I noticed no data was being generated in the Experience Profile. I went to the site and tried to generate some test data by filling out a form and received an error "Updating Contact Failed". I checked the logs for xConnect and saw the following:

[Error] A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

[Error] Sitecore.XConnect.Web.Infrastructure.Operations.GetEntitiesOperation`1[Sitecore.XConnect.Contact]: Sitecore.XConnect.Operations.DependencyFailedException: One or more dependencies failed ---> Sitecore.Xdb.Collection.Failures.DataProviderException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections.

[Error] ["XdbContextLoggingPlugin"] XdbContext Batch Execution Exception

I have verified that the xConnect URL is up and running and that SQL is configured to allow remote connections. I have updated the connection string for "collection" in the (site_name).xconnect project to use an admin account instead of the default Sitecore user.

  • Is SQL Browser service running? It's Windows Service so you can find it under Control Panel > Admin tools > Services. What is your setup? SQL Server is on seperate machine or it's on same? Do you use named instance? – Peter Procházka Oct 1 '18 at 16:10
  • I turned on SQL Browser service but it did not solve issue. This is a standalone instance so SQL is on the the same machine. SQL is a named instance. – Luke Pace Oct 1 '18 at 16:20
  • Do you have named pipes and tcp/ip enabled? Check these instructions blackbaud.com/files/support/infinityinstaller/content/… – Peter Procházka Oct 1 '18 at 16:25
  • I followed the instructions in the link but am still having the same issue. – Luke Pace Oct 1 '18 at 16:56
  • Can you add your connection string into question? Of course a bit obfuscated :) – Peter Procházka Oct 1 '18 at 17:24
1

Are you using SQL Express? If so, for SQL Express, try a different connection string. Instead of COMPUTERNAME\SQLEXPRESS, try using (local)\SQLEXPRESS.

Also verify that Named Pipes and TCP/IP connections are enabled for your SQL Express instance.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.