1

We need to get Sitecore SXA Installed on Sitecore 9.0 Update 2 we are aware that there are 2 ways to do this

1) Using Azure Market place module

2) Using ARM templates

The details are mentioned in this link : https://naveed-ahmad.com/2017/11/05/installing-sitecore-9-on-mircosoft-azure-cloud-as-paas-know-your-options/

But we have already installed Sitecore XP in PAAS and we want install the Sitecore SXA package the way we do in IAAS as mentioned in link.

https://www.rightpoint.com/thought/2016/11/17/install-guide-for-sitecore-experience-accelerator

So questions will we face any issue if we install SXA package in PAAS as we do in IAAS mode

  • We are doing this and using SItecore PAAS with SXA along with Solr in IAAS mode where Solr is exposed on Public IP and its working for us with no issues – Alivor Tikos May 17 at 13:52
1

I'm no PAAS expert, but this seems to be dependent on your redeployment. If you redeploy with the ARM templates (which I think is the best way to do it as you are sure of a clean setup) you can't just install SXA as you do in IAAS. But maybe you have another redeploy setup where doing this is possible.

So, my answer would be "yes, but...". Install SXA with the package to get the necessary items in your database. But rememember that your installation will succeed, but could be easily broken after the first redeploy. And you will not have SXA on the CD's. So, after installing it, you should set up your deployment using the SXA web deploy packages and change your ARM's to include SXA in the setup. Then perform a redeployment to your PAAS environment.

  • Another questions if i just grab the SXA CD.scwdp.zip & CMS scwdp.zip will i be able to install on the top of existing PAAS setup – user2332873 Oct 17 '18 at 16:12
  • I've used those indeed to install on PAAS. Added them to the templates I already had to install Sitecore - also don't forget SPE on the CM (SXA needs this). – Gatogordo Oct 17 '18 at 16:24
  • Sorry i didn't get it all i want is to install just these packages cdSxaMsDeployPackageUrl": "cmSxaMsDeployPackageUrl": "speMsDeployPackageUrl": Can you help with any code snippet – user2332873 Oct 17 '18 at 16:27
  • Sharing my ARM's won't do any good here as I get the feeling your deployment setup is diferent.. that's why I mentioned that. You might want to read this though (onelittlespark.bartverdonck.be/…) as this is the way I'm doing it – Gatogordo Oct 18 '18 at 11:38
0

Install the package in all of your environments as necessary. Add the supporting DLLs to your solution. I don't foresee any issues at that point with any future deployments.

The items will be in the Sitecore databases.

DLLs should get deployed with your solution.

EDIT: This is assuming you are not doing blue/green deployments.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.