1

I have configured CD server according to the official document and spreadsheet and also disabled anonymous IIS access to admin, login, shell folders and default.aspx file.

However, after changing IIS setting now I can see an error message in the Sitecore log as shown below:

 WARN  Request is redirected to document not found page. Requested url: /login.aspx?ReturnUrl=%2fsitecore%2f, User: extranet\Anonymous, Website: website

I am using sitecore version 8.2.7 and very new to this. Now I have no clue for how to fix this problem. Any thoughts?

  • Conrad is correct. Since you turned off anonymous access to the login page, it's not showing up anymore. – Gabbar Oct 25 '18 at 15:05
2

Is there actually a "problem"? The log warning is just telling you that someone tried to browse to /login.aspx (which apparently doesn't exist on your site, which is fine), and Sitecore responded with its normal default behavior (redirecting to "404" page). You can repro this yourself by browsing to /login.aspx on your site and see what happens.

These log warnings can be annoying, and you can preempt them by adding your own handler to the <httpRequestBegin> pipeline, but that's another question.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.