2

Publishing error enter image description here I'm getting an exception after every publish from CM.I try to publish a certain templates folder and any of its respective children specifically,

I'm using Sitecore 9.0.2, Solr 6.6.2 and sitecore sxa 1.7.1

Any ideas on what could be the cause of this exception would be great or how to solve it would be great. I've searched around for a while but I can't find anyone who got the same error and is using sitecore 9.0.2.

0
1

I got similar error when installing sitecore commerce. This is a known issue and there is a patch provided by sitecore at https://github.com/sitecoresupport/Sitecore.Support.13144/releases. Copy the Sitecore.Support.13144 dll into bin folder and it should fix the issue.

If the patch does not work for you, work around would be to find the event(with name item:moving) in SXA configuration file in App_config and comment it. enter image description here

7
  • i tried both, still it showing same publish error. Any idea related to this issue.
    – PKH
    Oct 29 '18 at 9:23
  • This is happening because of class Sitecore.XA.Foundation.Multisite.EventHandlers.VirtualMediaFolderValidator.You can try finding that in configuration and try it.If that does not work,find all the instances or configurations of events with name "item:moving" and comment it.looks like it is still missing some configuration files. Oct 29 '18 at 16:46
  • Thanks, i comment this line. its working fine for me, In workaround we can do like this.
    – PKH
    Oct 30 '18 at 0:42
  • when i publish the items, if i enable the related items checkbox in publish item popup. again i am getting same issue.
    – PKH
    Oct 30 '18 at 5:50
  • Check to see there are no references of "item:moving" in any config file in app_config folder. Oct 30 '18 at 17:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.