6

Using Sitecore 9.0.2, I'm looking to globally enable field-level language fallback. This seems like it should be easy to do, just go to the Field template and check on the box in the standard values. However, this doesn't appear to work properly.

I found this article from 2016 about the issue, and Sitecore suggested it was a bug and provided a patch: https://learnsitecorebasics.wordpress.com/tag/field-level-fallback/. But it seems like this is still present today and was never patched in.

Before I either get Sitecore to send me the v9 equivalent patch, or patch it myself in a similar style using dotPeek to find what needs fixing where, I wanted to check the community to see if others have this issue and there's a better way, beyond manually setting the checkbox on every field.

  • As a note, Sitecore says they fixed this in the base system in 8.2.7 and 9.0.2, but so far I haven't gotten it working if I check on "enable field level fallback" on the standard values of /sitecore/templates/System/Templates/Template field – Ken McAndrew Oct 30 '18 at 13:18
6

Sitecore support finally got back to me. This functionality is working in Sitecore 9.0.2, but it requires a setting that's not in the Sitecore.config and is currently undocumented. To get this to work, add the following setting in a patch:

<setting name="LanguageFieldFallback.AllowStandardValuesForSharedLanguageFallback" value="true" />

Then if you go to /sitecore/templates/System/Templates/Template field/_Standard Values and check on the Enable field level fallback option, you'll get fallback enabled on every field in your site. You can create a new language version to check that you see it working.

EDIT: Based on my comment where a further bug was identified, Sitecore did identify the bug and assigned it bug ID 257222. A patch (DLL/config) is available for 9.0.2 (I don't know about 8.2.7). If someone needs it, I can either provide it, or check with Sitecore support and reference the bug ID to get the patch. It appears to have fixed the issues I had.

  • CAUTION - I'm removing my own checkmark on this answer, as doing this setting right now results in other bugs through the system. I've reopened the ticket with Sitecore and I'll update as I get a resolution. Basically sometimes we'd create a language fallback and get a null reference exception related to the setting/field involved. – Ken McAndrew Nov 19 '18 at 14:50
  • Checkmark restored with info on the patch needed to fully get this running. – Ken McAndrew Nov 21 '18 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.