6

I am facing data loss in our Testing server after making some template fields Shared. However, in my development machine, I still have all the values for those Shared fields which I have lost in the Test server. Furthermore, in Deployment Property Manager (TDS), I have set both content and templates to Deploy Always and Synchronize All Children.

Any idea how to get those values, or am I missing something?

  • What was the process you followed to deploy the newly-Shared fields to your testing environment? – Dan Sinclair Oct 30 '18 at 11:59
  • 1
    Did you re-sync TDS (all content based on these templates you changed) after the switch locally? You need to – Mark Cassidy Oct 30 '18 at 12:16
  • @DanSinclair TDS generates .update packages and we install them on Test. Then based on deployment properties, it decides what to install. – Foysal Oct 31 '18 at 8:46
2

Same happens for me. Multiple language enabled for my sitecore site.By creating all language versions for that item, solve data loss problem issue.

  • 1
    Thanks! fortunately it did the trick for me. – Foysal Nov 1 '18 at 10:39
3

This is a known bug in TDS that was fixed in version 5.7.0.21.

Release notes:

Fixed an issue with shared fields in __Standard Values not being reset properly when an update package is installed.

Specifically, the issue happens on templates that have precisely one shared field. Templates with more than one shared field are installed correctly.

Disclaimer

I recommend upgrading to the latest version 5.7.0.24 to be safe. My recollection is that this was actually fixed in version 5.7.0.22. 5.7.0.22 sticks in my head and is not listed on the TDS downloads page.

  • I am still not sure this is the case. We use updated package. Our process is - TDS generates .update packages and we install them on Test. Then based on deployment properties, it decides what to install. – Foysal Oct 31 '18 at 8:48
  • Did you try it? What you described is the same process we follow. – jrap Oct 31 '18 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.