-1

I have a distributed Sitecore 9 Update 2 XP1 on prem setup. Getting below exception only on the CD servers, upon refresh the error goes away. Any ideas to resolve this?

Server Error in '/' Application.

Index sitecore_marketingdefinitions_web was not found Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Sitecore.ContentSearch.Exceptions.IndexNotFoundException: Index sitecore_marketingdefinitions_web was not found

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[IndexNotFoundException: Index sitecore_marketingdefinitions_web was not found]
Sitecore.ContentSearch.ContentSearchManager.GetIndex(String name) +127 Sitecore.Marketing.Search.Observers.Activation.UpdateSearchIndexObserver1..ctor(ILogger1 logger, String databaseName, String searchIndex) +302
System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() +31
Microsoft.Extensions.DependencyInjection.ServiceLookup.ConstructorCallSite.Invoke(ServiceProvider provider) +339
Microsoft.Extensions.DependencyInjection.ScopedCallSite.Invoke(ServiceProvider provider) +116
Microsoft.Extensions.DependencyInjection.ServiceLookup.CallSite.Invoke(ServiceProvider provider) +111
Microsoft.Extensions.DependencyInjection.TransientCallSite.Invoke(ServiceProvider provider) +30
Microsoft.Extensions.DependencyInjection.ServiceLookup.ConstructorCallSite.Invoke(ServiceProvider provider) +111
Microsoft.Extensions.DependencyInjection.ScopedCallSite.Invoke(ServiceProvider provider) +116
Microsoft.Extensions.DependencyInjection.ServiceLookup.ConstructorCallSite.Invoke(ServiceProvider provider) +111
Microsoft.Extensions.DependencyInjection.ScopedCallSite.Invoke(ServiceProvider provider) +116
Microsoft.Extensions.DependencyInjection.ServiceLookup.ConstructorCallSite.Invoke(ServiceProvider provider) +111
Microsoft.Extensions.DependencyInjection.ScopedCallSite.Invoke(ServiceProvider provider) +116
Microsoft.Extensions.Internal.ConstructorMatcher.CreateInstance(IServiceProvider provider) +127
Microsoft.Extensions.Internal.ActivatorUtilities.GetServiceOrCreateInstance(IServiceProvider provider, Type type) +69
Sitecore.Configuration.DefaultFactory.CreateFromServiceProvider(XmlNode configNode, Boolean assert) +483

[ConfigurationException: Could not create object from service provider . Config XML: ]
Sitecore.Configuration.DefaultFactory.CreateFromServiceProvider(XmlNode configNode, Boolean assert) +646
Sitecore.Configuration.DefaultFactory.CreateObject(XmlNode configNode, String[] parameters, Boolean assert, IFactoryHelper helper) +138
Sitecore.Configuration.DefaultFactory.CreateObject(XmlNode configNode, Boolean assert) +68
Sitecore.Pipelines.CorePipelineFactory.GetObjectFromType(XmlNode processorNode) +91
Sitecore.Pipelines.CorePipelineFactory.GetProcessorObject(XmlNode processorNode) +145
Sitecore.Pipelines.CoreProcessor.GetMethod(Object[] parameters) +138
Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) +480
Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain, Boolean failIfNotExists) +285 Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain) +22
Sitecore.Web.RequestEventsHandler.OnPostAuthenticateRequest(HttpContextBase context) +214 Sitecore.Nexus.Web.HttpModule.(Object , EventArgs ) +335 System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +139 System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step) +197 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +88

marked as duplicate by Vlad Iobagiu, Peter Procházka, Hishaam Namooya, Bartłomiej Mucha, Patrick Barron Nov 5 '18 at 14:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

I'm not sure exactly why it can't find the index, however it's best practice to avoid having the CD server(s) do any indexing and leave that to another role. This is to leave the CD server resources for doing actual content delivery instead of other background tasks such as indexing.

See here for a good post on how to do this with patch configs.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    I understand that this question was similar to the one already being asked before, this essentially is not a duplicate question. We did reach out to sitecore support and they recognized this as an issue with the scaled XP1 installation for sitecore 9.0 update 2. They have a patch for this now, below are the details -Patch: Sitecore.Support.255663 Version: 9.0.2.2 Revision: 181115 Description UpdateSearchIndexObserver may fail at construction Compatibility - Sitecore – Abhi Nov 15 '18 at 17:41
  • I have voted to reopen the question so you can add the correct answer. – Mark Gibbons Nov 15 '18 at 23:57
  • It's still a duplicate question. The answer needs to be added to the one we already have in place - that covers all other bases. When new information around an existing answer arises, additional answers should be added to the existing question. – Mark Cassidy Nov 16 '18 at 0:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.