6

We're trying to validate a Droptree field to only allow a certain template type be selected. We've found the /sitecore/system/Settings/Validation Rules/Field Rules/System/Linked Item Has Allowed Template; the only field rule validator that is within Sitecore.Marketing.Taxonomy, all others are within Sitecore.Kernel:

Sitecore.Marketing.Taxonomy.Validators.LinkItemTemplateValidator,Sitecore.Marketing.Taxonomy

We've created a new validator that references the Type above and set the Parameters to several variations of the following with no luck:

  • IncludeTemplatesForSelection={5A0F5DE2-8209-438E-A281-F8E8479B9565}
  • IncludeTemplatesForSelection="{5A0F5DE2-8209-438E-A281-F8E8479B9565}"
  • IncludeTemplatesForSelection="Event"
  • IncludeTemplatesForSelection="/sitecore/templates/Event"

Has anyone had success with this validator? Any help would be much appreciated, thanks!

  • Try IncludeTemplatesForSelection="Template Name" – Siva Kumar Nov 22 '18 at 12:50
  • @SivaKumar thanks for the reply, but still nothing. – HCFLGov Nov 26 '18 at 15:55
3

“Linked Item Has Allowed Template” Field Validator is working as expected for Droptree field. You need to add DataSource=/sitecore/content/Home&IncludeTemplatesForSelection=Template Name in Source field.

Note: IncludeTemplatesForSelection should be equal to Template Name without double quotes.

enter image description here

  • This appears to be an invalid entry in the Source field: The item "Related Event" contains broken links in these fields: Source IncludeTemplatesForSelection=Event – HCFLGov Nov 28 '18 at 21:31
  • However, it does seem to work. Is there a way to include the IncludeTemplatesForSelection parameter with a starting point in the content tree? For example:/sitecore/content/Home/Calendar – HCFLGov Nov 28 '18 at 21:39
  • This looks like it might do the trick: DataSource=/sitecore/content/Home/Calendar&IncludeTemplatesForSelection=Event. Thanks for your help! – HCFLGov Nov 28 '18 at 21:48
  • Thank you. I missed adding Datasource. I'll edit the comment. – Siva Kumar Nov 29 '18 at 4:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.