2

I have 2 Sitecore 9.02 Scaled Azure environments.

They are PROD and UAT. All the databases are SQL Azure.

The marketing team have been adding a lot of content on PROD and I want to take a bacpac of PROD master DB and restore it on UAT to sync the environments.

The problem I have is that when I look at the password of [masteruser] they are different in the connection string and when I run a CREATE USER script in SQL Azure.

  1. Connection string [masteruser] password - FXZAAX32E5AIIobsf5ved75bjcOBSF5VED75BJC4@
  2. CREATE USER SQL Script password - sOL4NyuCx9UcjR0lpcmznHNsVcZv/HFFgGd9vmHMfwQ=

To me it looks like the password in the CREATE USER SQL is a hash.

When I restore the master DB from PROD I try and update the password for the [masteruser] to be the same as the connection string and the CM server immediately errors with "cannot login for masteruser"

i have also tried deleting the masteruser and recreating with a new password, but this doesn't work either.

Can anyone offer any advice on this?

3

The Sitecore ARM templates will generate a password for the database users similar to the format FXZAAX32E5AIIobsf5ved75bjcOBSF5VED75BJC4@. See here for how this is done in the template.

Something to note is that the usernames and passwords are unique to each database. You can change the password via SQL by running this against the database you want to change:

ALTER USER masteruser WITH PASSWORD = 'NewPassword'

You can then change the connection string to use the new password:

<add name="master" connectionString="Data Source=...;Initial Catalog=...;User ID=masteruser;Password=NewPassword" />

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.