3

I'm using VS 2017 and Sitecore 9

I have tried installing Sitecore Rocks multiple times, each time I follow the steps:

Tools > Extensions and updates > search for "rocks" in the online tab > Install > Restart VS to trigger installation > installation finishes "successfully"

However, it doesn't work : the extra "Sitecore" tab doesn't appear, and whenever I try to check Sitecore Rocks in "Extensions and updates", it appears to be disabled, like this:

enter image description here

I've been looking online for hours and I can't find anything similar to this, can anyone help? What should I do to enable it? Am I missing any steps in the installation process?

2
5

Your solution can be found here: https://blog.mastykarz.nl/installed-visual-studio-extension-doesnt-work/

The reason for your problem is the setting of Visual Studio which disallows loading per user extensions while running as administrator. This message is displayed at the bottom of the Extension Manager – as you can see in the screenshot.

You can fix this by clicking the Enable loading of per user extensions in the Extension Manager or via Tools > Options > Environments > Extension and Updates > Load per user extensions when running as administrator.

enter image description here

Restart VS and the plugin should be enabled.

3
  • 1
    I followed your steps, and it did become "Enabled", however, the "Sitecore" tab in the toolbar is still not appearing, (where we should connect from), do you have any idea why that might be? Nov 11 '18 at 14:18
  • 1
    Not really.. maybe you should reinstall with this settings enabled.. but that is just a guess.
    – Gatogordo
    Nov 11 '18 at 14:59
  • That did the trick! i uninstalled and reinstalled with the setting enabled as you said, thanks a lot! Nov 11 '18 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.