6

In this curious case I'm facing here, I'm unable to change any item's Display Name.

I have tried changing DisplayName from Ribbon menu, from Appearance section and Sitecore Rocks. I can write new text but after save when item is reloaded it is still old Text in DisplayName. I have tried cache clearing as well.

I have tried lot different of ways to track down if the issue is with Sitecore setup, or My code (like may be events handlers, pipelines, etc), or may be database.

Finally found that issue is with database when i tried this database with clean Sitecore instance pointing it. And I was able reproduce the editing not working anymore in clean Sitecore instance.

Next I'm not sure how to identify what is the issue in this database that I'm unable to edit Display Name only. Rest of the fields I'm able to edit.

Note: Sitecore 7.5 update-2

Kindly help.

  • 2
    What do you mean by "cannot edit"? There is no option to edit? No button in ribbon? You're getting some exception? Have you tried to update Display Name field from the Appearance section in Content Editor? – Marek Musielak Oct 17 '16 at 18:55
  • I have tried from Ribbon menu and from Appearance section both ways but after submitting and reload, Sitecore Content Editor still shows old text. I have even tried editing from Rocks but no change in issue. – Harsh Baid Oct 17 '16 at 19:02
  • Could it be bug 381251: "Display name dialog shows Item Name instead of Display Name when the Item Key option is enabled" ? That was fixed in some releases already but not in yours. – Gatogordo Oct 17 '16 at 19:07
  • This question on SO sounds like same problem I'm having. I will update soon on this with results from my copy of DB. – Harsh Baid Oct 17 '16 at 19:15
  • 1
    You don't have some rules in the rules engine applying perhaps that are forcing the name and display name to be the same do you? – Adam Seabridge Oct 17 '16 at 20:03
2

Based on comments, the answer to this question appears to be data issue within the Sitecore Database itself. It appears the issue resolved itself after performing a database restore.

So, some conjecture on how this might happen:

  • If the Display Name field was somehow duplicated indicating that there were two fields with the same Name in the database, but with different Item ID's, I could see how this would possibly happen. But to be honest, I'm having a difficult time replicating a similar scenario.

  • A failed upgrade package install which might have left bad item id's in the database.

  • Index or cache confusion

Resolution to fix this issue as it stands appears to be to restore the database.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.