-1

We have sitecore 9 forms with basic single-line texts, multi-line texts, dropdown list, radio button list etc. The form works fine in CM. But when we publish all and try to view the form page in Content Delivery, single-line texts, multi-line texts do not show up, whereas dropdown lists, radio button lists display properly. Any idea what could be the reason?

3
  • Have you published everything, including Form templates under /sitecore/Templates/System/Forms and items under /sitecore/System/Forms. Failing that try a Full Republish also.
    – jammykam
    Nov 15 '18 at 3:37
  • Yes we published/republished everything. The moment we change that single-line text to a dropdown list, it shows up. But no single-line, muti-line text etc display. Nov 15 '18 at 4:52
  • Did you switch tot web db to verify that it is a publishing issue? Nov 15 '18 at 6:35
1

please make sure that your Form items are correctly pushed to Web DB - test at your CM in the published mode as well.

If the behavior is still different from CM to CD in publish mode, then it has to be something with files instead of items. In that case, please make sure to compare your DLLs and Views between CM and CD. If they are not identical, please make sure to have your CD files matching the CM.

If none of these works, you might want to open a ticket with Sitecore Helpdesk, as it might be a bug that they can fix in a next version.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.