1

I am using Sitecore 8.1 with Mongo and Lucene indexes.

I rebuilt the Reporting Database before - it never took more than 10 hours. This time, my PC has been running it for more than 3 days straight.

So far, the only odd symptom is the presence of this exception:

ERROR Exception in alarm clock event subscriber.
Message: Binary stream '0' does not contain a valid BinaryHeader. 
Possible causes are invalid stream or object version change between serialization and deserialization.

Every single minute. Which needs investigating, but surely does not justify a three-fold increase of rebuild time. Is there anything I can do to gauge the progress of the rebuild, and troubleshoot performance?

  • 1
    Do you see anything on the jobs admin page? (/sitecore/admin/jobs.aspx) – Dan Sinclair Nov 16 '18 at 12:53
  • I have now stopped it - I will restart it this weekend, and will definitely check it. – Emanuele Ciriachi Nov 16 '18 at 15:14
  • Hi, I don't have a jobs admin page (Sitecore 8.1 here). Do I need a plugin or third-party module? – Emanuele Ciriachi Jan 23 at 10:46
  • 1
    The jobs admin page was released in Sitecore 8.1 Update-2, so consider upgrading? :) In all seriousness, though, you might be able to download a later version of Sitecore (8.1u2 or 8.1u3) and add the jobs.aspx page to your /sitecore/admin folder and it may just work. – Dan Sinclair Jan 23 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.