5

I am using Sitecore (9.0 update 2) Geo IP service. For that I have installed Sitecore IP Geolocation Service Client 1.2 package from https://dev.sitecore.net/Downloads/Sitecore_IP_Geolocation_Service_Client/12/Sitecore_IP_Geolocation_Service_Client_12_for_Sitecore_XP_80.aspx

I have downloaded TestIpPage from https://kb.sitecore.net/articles/798498 solution 3 section. When I am testing the http://local.sitecoredemo/sitecore/TestIp.aspx page and clicked on GetInformationByIp.

I am getting the following error: Could not create instance of type: Sitecore.CES.GeoIp.SitecoreProvider. No matching constructor was found.

Below is the screenshot of the error enter image description here

5

You installed a module for Sitecore 8 on a Sitecore 9 site. From Sitecore 8.1 and higher, you don't need that module - it's already included.

Check the documentation on https://doc.sitecore.net/sitecore_experience_platform/setting_up_and_maintaining/ip_geolocation/ip_geolocation/setting_up_sitecore_ip_geolocation but be sure to read it for your Sitecore version. Latest update is for 9.0.1 which should be ok for you.

Sitecore IP Geolocation is included in the initial version of Sitecore Experience Platform 8.1 (Sitecore XP) and all later versions by default, it is also tested with all subsequent updates. This means you only need to subscribe to the Sitecore IP Geolocation service.

  • I have removed the module but still getting the same error when i access that page.Should i install sitecore Geo IP service from app center?One of my colleague said,updating licence with Geo Ip services should fix it without installing Geo IP services.We updates licence but still getting same error.Remember i have not installed GeoIP services from app module as it is asking me to enter user name and password which i do not have. – Sriram Rakesh Nov 18 '18 at 17:38
  • Start by checking your filesystem. Compare the bin (and if needed config) folder with a clean Sitecore 9.0.1 to make sure the files match. – Gatogordo Nov 18 '18 at 18:03
  • 1
    The module was probably not removed correctly. If the config files from it are still present, the error will remain. – Mark Cassidy Nov 19 '18 at 1:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.