2

I have enabled allowKeepAlive setting for my application on IIS by set common header (as shown below) but getting connection as close every time in response header.

enter image description here

enter image description here My application is developed using Sitecore 9.0.1, IIS 10, .Net Framework 4.6.2.

I am not getting what I have missed. Followed the given URL Enable the HTTP Keep-Alive

Any help is much appreciated.

3
  • 1
    Are you sure it's Sitecore 9.1 - I think you mean Sitecore 9.0.1, no?
    – Gatogordo
    Nov 21, 2018 at 16:05
  • @Gatogordo Yes you are right, it is Sitecore XP 9.0.1. It was a typo.
    – SumitK
    Nov 27, 2018 at 3:50
  • 1
    can you try this by running the following command go to %windir%\system32\inetsrv and run appcmd.exe To enable the HTTP keep-alive header, use the following syntax: appcmd set config /section:httpProtocol /allowKeepAlive:true | false
    – Hem Kant
    Nov 27, 2018 at 12:47

1 Answer 1

1

After debugging a lot and implementing lost of fixes I was advised to check with hosting provider.
Then I cross checked with hosting provider of the website and found that Keep-Alive was disabled on domain.
By default keep-alive is enabled on server for all domain hosted on that server.
Posting this as answer for reference in case anybody face the same issue, so can be looked in that direction as well.
Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.