6

I am starting up my Sitecore 9.1 XP instance and I see the following error from Sitecore.Nexus:

[NullReferenceException: Object reference not set to an instance of an object.]
   Sitecore.Nexus.Licensing.NexusLicenseApi.HasModule(String name) +146
   Sitecore.Xdb.Configuration.XdbSettings.get_HasValidLicense() +21
   Sitecore.Xdb.Configuration.XdbSettings.get_Enabled() +8
   Sitecore.Xdb.Configuration.Pipelines.Initialize.ShowXdbInfo.Process(PipelineArgs args) +223
   (Object , Object ) +8
   Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) +483
   Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain, Boolean failIfNotExists) +235
   Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain) +21
   Sitecore.Nexus.Web.HttpModule.Application_Start() +214

Also, my FakeDb tests are failing with the following exception:

System.NullReferenceException
Object reference not set to an instance of an object.
   at Sitecore.Nexus.Licensing.NexusLicenseApi.GetSnapShot(Guid instance)
   at Sitecore.SecurityModel.License.LicenseManager.GetSnapshotData(Guid instance)
   at Sitecore.SecurityModel.License.LicenseManager.UpdateSnapshot()
   at Sitecore.SecurityModel.License.LicenseManager..cctor()

What could be causing this?

6

In Sitecore 9.1, this could indicate that your license.xml is missing from your data folder, which will typically be your App_Data folder. Place the license file in the correct location, and reset your application pool.

With FakeDb on Sitecore 9.1, this could also indicate that your license.xml is missing from the unit test root or the LicensePath is misconfigured in your App.config. Be sure you follow the FakeDb Installation Documentation to make your license file available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.