5

After referencing Sitecore.Kernel via the Sitecore 9.1 Platform nuget feed, I am seeing the following build error:

Sitecore.Nexus 3.0.0 depends on Sitecore.Nexus.Licensing (>= 2.0.3 && < 3.0.0) but Sitecore.Nexus.Licensing 2.0.3 was not found. An approximate best match of Sitecore.Nexus.Licensing 2.0.5 was resolved.

I have confirmed that indeed the feed is missing version 2.0.3 of Sitecore.Nexus.Licensing, but I assume version 2.0.5 is OK? How do I prevent this error from breaking my build?

6

This is a known/discussed nuget issue -- what seems like information is output by nuget as a build error. As of 9.1 the published nuget packages are those used internally by Sitecore ("release what you test"), so in dependency version ranges they may reference versions that are not released publicly.

You can suppress this error in your project's build configuration:

Suppress NU1603

You can also add the property directly to the project file:

<NoWarn>NU1603</NoWarn>
3

This warning can be ignored. The official and released version of Sitecore.Nexus.Licensing for Sitecore 9.1.0 is version 2.0.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.