13

Following this article https://buoctrenmay.com/2018/01/11/playing-with-sitecore-9-0-update-1-installation/comment-page-1/#comment-548 to install Sitecore, got this error on step 13, any idea?

[---------------------------------------- CreateSignedCert : NewSignedCertificate ------------------------------------] VERBOSE: Resolving ConfigFunction extension 'GetCertificate' VERBOSE: Resolved 'Invoke-GetCertificateConfigFunction' VERBOSE: Invoke-GetCertificateConfigFunction VERBOSE: Id: DO_NOT_TRUST_SitecoreRootCert VERBOSE: CertStorePath: cert:\LocalMachine\Root VERBOSE: Found Cert(s) with thumbprint: C6641D4F4CEB3790FCFC82928ED5C2B74B68EDEB Install-SitecoreConfiguration : Cannot validate argument on parameter 'Signer'. The "$_.HasPrivateKey -eq $true" validation script for the argument with value "[Subject] CN=DO_NOT_TRUST_SitecoreRootCert, O=DO_NOT_TRUST, OU=Created by https://www.sitecore.com [Issuer]
CN=DO_NOT_TRUST_SitecoreRootCert, O=DO_NOT_TRUST, OU=Created by https://www.sitecore.com [Serial Number]
575C8CA6DFB4129D49F47FA7681558D4 [Not Before] 11/28/2018 5:32:24 AM [Not After] 11/26/2028 5:32:24 AM [Thumbprint]
C6641D4F4CEB3790FCFC82928ED5C2B74B68EDEB " did not return a result of True. Determine why the validation script failed, and then try the command again. At C:\Sitecore9\Sitecore 9.0.2 Single Instance\Sitecore902Install.ps1:18 char:1 + Install-SitecoreConfiguration @certParams -Verbose + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:02 Invoke-NewSignedCertificateTask : Cannot validate argument on parameter 'Signer'. The "$_.HasPrivateKey -eq $true" validation script for the argument with value "[Subject]
CN=DO_NOT_TRUST_SitecoreRootCert, O=DO_NOT_TRUST, OU=Created by https://www.sitecore.com [Issuer] CN=DO_NOT_TRUST_SitecoreRootCert, O=DO_NOT_TRUST, OU=Created by https://www.sitecore.com [Serial Number] 575C8CA6DFB4129D49F47FA7681558D4 [Not Before] 11/28/2018 5:32:24 AM [Not After] 11/26/2028 5:32:24 AM [Thumbprint]
C6641D4F4CEB3790FCFC82928ED5C2B74B68EDEB " did not return a result of True. Determine why the validation script failed, and then try the command again. At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.0.0\Public\Install-SitecoreConfiguration.ps1:641 char:47 + & $entry.Task.Command @paramSet | Out-Default

Error

  • Where having same issue with the certificate, where you able to manage this? – user2268949 Dec 6 '18 at 8:42
  • If one of the proposed answers fixed your issue, could you please accept that answer? – Dan Sinclair Apr 5 at 14:17
21

Below solution worked for me.

Close all active PowerShell sessions, delete all DO_NOT_TRUST* certificates from all certificate store and C:\certificates. Open “xconnect-createcert.json” and change json as below.

"StoreLocation": "LocalMachine",

https://mohitdharmadhikari.com/2018/12/25/cannot-validate-argument-on-parameter-signer-sitecore-9-installation/

5

Encountered the same exact error today. It looks like a new version of the SitecoreInstallFramework was published November 28th (version 2.0.0). It seems to break the process in some way. I solved this by uninstalling the framework and reinstalling with version 1.2.1.

  • In my case installing SIF 1.2.1 did not work as well, because the certificates generated are already expired (2018-11-29) – Rodrigo Peplau Dec 5 '18 at 16:14
1

I found that I was using Sitecore Installation Framework version 2.1.0 to install Sitecore version 9.0.1, which does not work. I ran the following to switch the SIF version:

Remove-Module SitecoreInstallFramework
Import-Module SitecoreInstallFramework -RequiredVersion 1.1.0

And then deleted the created certificates from previous attempts as per Mohit's answer.

You can determine which versions of SIF you have with this:

Get-InstalledModule -Name SitecoreInstallFramework -AllVersions

Hope his helps.

0

This can happen if you tried to install sitecore 9 in the past. Changing "RootCertFileName" default value in xconnet-createcert.json to, for example, SIF121Root, fixes the issue.

This link helped me out https://kb.sitecore.net/articles/699694

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.