I am trying to install Sitecore 9.1.0 rev. 001564 (WDP Package XP0) and I get this error:

WARNING: (sc910.xconnect-MarketingAutomationService)' to start...
WARNING: Waiting for service 'Sitecore Marketing Automation Engine - sc910.xconnect-MarketingAutomationService
WARNING: (sc910.xconnect-MarketingAutomationService)' to start...
WARNING: Waiting for service 'Sitecore Marketing Automation Engine - sc910.xconnect-MarketingAutomationService
WARNING: (sc910.xconnect-MarketingAutomationService)' to start...
WARNING: Waiting for service 'Sitecore Marketing Automation Engine - sc910.xconnect-MarketingAutomationService
WARNING: (sc910.xconnect-MarketingAutomationService)' to start...
Install-SitecoreConfiguration : Failed to start service 'Sitecore Marketing Automation Engine -
sc910.xconnect-MarketingAutomationService (sc910.xconnect-MarketingAutomationService)'.
At C:\ResourceFiles\XP0-SingleDeveloper.ps1:80 char:1
+ Install-SitecoreConfiguration @singleDeveloperParams *>&1 | Tee-Objec ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

Any idea? Thank you.

Possible Cause:

The untrusted certificates installed under the Trusted folder.

Solution:

Execute this command as Administrator, delete the database and run the script of installation again:

Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} | Move-Item -Destination Cert:\LocalMachine\CA

enter image description here

Please add a comment if this solution works for you.

up vote 6 down vote accepted

This is telling you that the service that xConnect is trying to install for the Marketing Automation Engine is not starting. This could stem from a number of different causes. However, generally, it could be a result of either permission issues with the service and or folder. The image below shows the services in Windows.

enter image description here

Troubleshooting Steps

  1. Try to start the service manually from the Windows Services window.
  2. Check the Windows Event Log. When services fail, it logs a message in the Application Log which is usually helpful enough to understand what's going.
  3. Ensure that you are using a PowerShell window as An Administrator. The SIF process installs Windows Services, which needs administrator access to the machine.
  4. Look at the xConnect Marketing Automation Engine logs. See below.
  5. Enure that Local Service account has full control over the c:\inetpub\wwwroot\*.xconnect folder and it's subfolders and files.

Looking at MA Engine Logs

Another step of troubleshooting is to look at the MA Engine logs. It could be the service is throwing an error. Look in c:\inetpub\wwwroot\*.xconnect\App_Data\jobs\continuous\AutomationEngine\App_Data\logs

enter image description here

Check errors in this log. A properly working engine will have the following log:

2018-12-02 14:10:47.423 -05:00 [Information] SystemPerformanceCounters Constructor, Instance:MarketingAutomation, Path: C:\inetpub\wwwroot\sxp910.xconnect\App_Data\jobs\continuous\AutomationEngine\App_Data\Diagnostics, CounterFilePattern: *.json
2018-12-02 14:10:49.952 -05:00 [Information] Engine configurator "PoolWorkerRatioEngineConfigurator" will create 8 pool workers
2018-12-02 14:10:49.962 -05:00 [Information] Adding pool worker with ID 'c21836e0-97f7-4d1e-b881-265fcd9d9508'
2018-12-02 14:10:49.962 -05:00 [Information] Adding pool worker with ID '8ec6d988-cf33-4e45-bfb5-0e5f693d8ac4'
2018-12-02 14:10:49.963 -05:00 [Information] Adding pool worker with ID '1e69254a-79c2-4c3a-b665-d130c9c06a78'
2018-12-02 14:10:49.963 -05:00 [Information] Adding pool worker with ID 'a55ae68e-a3b0-4b80-9978-7f7f939c154c'
2018-12-02 14:10:49.963 -05:00 [Information] Adding pool worker with ID 'c5b5be38-107d-45aa-ab24-5211638a1123'
2018-12-02 14:10:49.963 -05:00 [Information] Adding pool worker with ID '827b6de6-6e5f-42ab-9862-4c805bfd26cb'
2018-12-02 14:10:49.963 -05:00 [Information] Adding pool worker with ID '36fd10a3-165d-4a10-9be4-195ff964a3c6'
2018-12-02 14:10:49.963 -05:00 [Information] Adding pool worker with ID '4132a778-c5d5-4532-9ca8-fb202d73c32c'
2018-12-02 14:10:49.965 -05:00 [Information] Starting workers
2018-12-02 14:10:49.968 -05:00 [Information] Starting worker with ID 'c21836e0-97f7-4d1e-b881-265fcd9d9508'

Resolving

Once you have identified what the issue is and have resolved it (meaning that you can manually start the windows service without error), try to rerun the Sitecore 9.1 SIF installation script. You may need to uninstall the services that were set up by the previous installation of SIF.

Last Resort

Delete everything and try again. Making sure that you have an Administator Powershell command prompt and that you have the correct version of Sitecore Install Framework installed.

  • Thank you for your help, I tried to start the three services, two started and "sc910.xconnect-MarketingAutomationService" not, I check the Event Viewer and I get this messages: (System: An exception occurred in the service when handling the control request.) (Application: Faulting application name: maengine.exe, version: 3.0.0.0, time stamp: 0xc338dcf1 Faulting module name: KERNELBASE.dll, version: 10.0.17134.407, time stamp: 0x99042cc0 Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll) – Abd Dec 2 at 21:35
  • I've edited my answer to add checking the MA Engine log. See above. – Pete Navarra Dec 2 at 21:46
  • I check the log and if found this: 2018-12-02 21:26:57.724 +00:00 [Error] Failed to start the Marketing Automation Engine service. System.InvalidOperationException: This configuration has not been initialized. Please call the initialize method before using it. at Sitecore.XConnect.Client.XConnectClientConfiguration.CheckInitialized() at Sitecore.XConnect.Client.XConnectClientConfiguration.get_CurrentModel() at Microsoft.Extensions.DependencyInjection.ServiceLookup.CallSiteRuntimeResolver.VisitScoped(ScopedCallSite scopedCallSite, ServiceProviderEngineScope scope) – Abd Dec 2 at 22:03
  • I would add that to your question. This just seems like a completely failed installation. I would delete everything and try again. Make sure that you are using a PowerShell Window in Administrator mode when running SIF and that you have updated SIF correctly. – Pete Navarra Dec 2 at 22:10
  • I will do it now, and I let you know, thank you for your help you are the best. – Abd Dec 2 at 22:13

I had the same issue. What happens is that during startup, the marketing service tries to connect to xConnect. But xConnect could not startup. Hence the marketing service failed, and thus the installation.

The reason xConnect could not startup was due to this error in the event logs:

Windows cannot find the local profile and is logging you on with a temporary profile.
Changes you make to this profile will be lost when you log off.

This has to do with the custom user that is created in the script and the identityType set to "ApplicationPoolIdentity" on the application pool of xConnect.

This issue can be resolved by setting "Load User Profile" to false in the advanced settings of the application pool.

Solution

To fix the install script so that no manual interventions are required edit these files:

  • xconnect-xp0.json
  • sitecore-xp0.json
  • identityserver.json

In each file search for

"identityType": "ApplicationPoolIdentity"

and change this to

"identityType": "ApplicationPoolIdentity",
"loadUserProfile": "False"

I experienced the same issue and looking into the Automation Engine logs I could see that before the failed initialisation, it was throwing an xConnect connection error:

Sitecore.XConnect.XdbCollectionUnavailableException: The HTTP response was not successful: Forbidden

Looking at the IIS logs, it was throwing a 403.16 and some googling led me to this post: https://sitecorecorner.com/tag/ssl/

which in turn took me to the solution here:

https://stackoverflow.com/questions/26247462/http-error-403-16-client-certificate-trust-issue

The issue was that there were some non-self-signed certificates in the Trusted Root Certification Authorities (i.e. Root) store. The second post listed above provides some handy Powershell that fixed the problem by removing the offending certificates. The certificates in my case were installed as part of my company's standard Windows 10 image.

I ran into the same problem. My solution was to enable Windows ASP.NET 4.7 Application Development Features. These settings are found in Windows Features -> Internet Information Services -> World Wide Web Services -> Application Development Features -> ASP.NET 4.7

The Marketing Automation service would not start because xConnect was not working correctly. Enabling the appropriate Windows Features fixed xConnect.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.