5

After the release of SIF 2.0.0, an automated SC 9.0.x script began failing with the error:

The operation is on user root store and UI is not allowed.

This error occurs during the execution of xconnect-createcert.json, which is included in the SC On-Prem WDP package > Configuration Files zip.

After inspecting xconnect-createcert.json, I noticed that it specifies CurrentUser as the Store Location for the cert.

My script runs as the System user account as part of the DSC (Desired State Configuration) execution on a VM created via an Azure ARM template.

If I explicitly request SIF 1.2.1, the certificate is installed properly. Strangely, with 1.2.1, the cert is installed in the LocalMachine store. I suspect SIF 1.2.1 has some additional code to ensure this Store Location is used.

12

As discussed on the #sif Sitecore Slack channel, when using vanilla SC WDP configs the SIF version does have a dependency on the installed SC version.

  • SIF 2.0.0 = SC 9.1
  • SIF 1.2.1 = SC 9.0.x

There are two ways to solve the problem outlined above.

1) Define SIF Version Explicitly

If installing SIF for the first time via PowershellGallery:

Install-Module -Name SitecoreInstallFramework -Repository SitecoreGallery -RequiredVersion 1.2.1

If SIF 2.0.0 was previously installed, you will need to first uninstall then reinstall with the proper version:

Uninstall-Module -Name SitecoreInstallFramework

2) Modify Config Files Prior to Installation

To use SIF 2.0.0 to install SC 9.0.x...

Modify xconnect-createcert.json

  1. Find the CreateRootCert task
  2. Change the StoreLocation from CurrentUser to LocalMachine

Modify xconnect-solr.json and sitecore-solr.json

  1. Find the CreateCores task in each file
  2. Change the "Name" attribute in Params > Action to lowercase "name"

Original Example

{ "Action": "Create", "Address": "[parameter('SolrUrl')]", "Arguments": { "Name": "[variable('Core.Name')]" } },

Updated

{ "Action": "Create", "Address": "[parameter('SolrUrl')]", "Arguments": { "name": "[variable('Core.Name')]" } },

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.