1

We are using a custom patch into Sitecore.config to define our own site node. It has pretty much the exact same settings as the default "website" site node except for the name, hostname and rootpath. It even has enableWebEdit set to true. When we remove the default website node, Experience Editor (specifically edit mode) no longer works. By that I mean, there are no editable regions for each field, and clicking on text does not give the user the feel they can change the text. It acts pretty much like preview mode.

We are just really curious why Sitecore needs the default website node for the XP editor to work? We are using Glass().Editable() in our views, in case it matters.

4
  • 1
    Did you configure a new default site for it? sitecore.stackexchange.com/a/477/73
    – Mark Cassidy
    Commented Dec 3, 2018 at 23:22
  • Can you post what version of Sitecore? Commented Dec 3, 2018 at 23:58
  • @MarkCassidy No, but upon discovering that setting and changing it to the name of our custom site node, we are able to remove or comment out the website node in Sitecore.config and the Experience Editor still works. I think this is the solution.
    – Paul
    Commented Dec 4, 2018 at 0:21
  • @PeteNavarra Sitecore 8.2 rev. 161115
    – Paul
    Commented Dec 4, 2018 at 0:22

1 Answer 1

2

In versions of Sitecore 8.1 and above, the proper way to set the preview site DefaultSite is to set the configuration setting Preview.DefaultSite to something other than website.

<setting name="Preview.DefaultSite" value="mysite1"></setting>

This might be a duplicate of question:

https://sitecore.stackexchange.com/a/477/246

2
  • This is great to know, but we are currently on 8.2 rev. 161115, so I don't think it applies.
    – Paul
    Commented Dec 4, 2018 at 0:23
  • We were able to fix it be changing the Preview.DefaultSite property in Sitecore.config to the name of our custom site node.
    – Paul
    Commented Dec 4, 2018 at 1:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.