I am trying to install sitecore XP1 architecture. I already have a signed certificate. My issue comes when I try to configure sitecore on my solr. Sitecore 9.0.1 rev. 171219. SOLR 6.6.4. Windows server 2016. JRE 1.8.0_191

What I did :

  1. Installed iis
  2. Installed Web Platform Installer
  3. Installed Java JRE (and add java_home to the Environment Variables)
  4. Installed SOLR (and created a service with NSSM to run solr at boot time)
  5. Installed certificate with keytool.exe // configure solr.in.cmd // bind iis with the certificate
  6. Installed FrameWork Sitecore from MyGet

Until here everything is working fine. The service is running and I can connect to my SOLR in HTTPS.

Issue : When I run this command

$solrParams =
    Path = "C:\Sitecore\installer\config\xconnect-solr.json"     
    SolrUrl = "https://blabla.bla.com:8984/solr"    
    SolrRoot = "C:\Sitecore\solr-6.6.4"
    SolrService = "solr"
    CorePrefix = "sc_pprd"
Install-SitecoreConfiguration @solrParams -Verbose

I can see everything is going great without any warning then the CreateCores step fail:

[------------------------------------------------------ CreateCores [1] : ManageSolrCore -------------------------------------------------------]
VERBOSE: Performing the operation "Requesting" on target "https://blabla.bla.com:8984/solr".
[CreateCores [1]]:[Requesting] https://blabla.bla.com:8984/solr
VERBOSE: GET https://blabla.bla.com:8984/solr with 0-byte payload
VERBOSE: received 13592-byte response of content type text/html;charset=utf-8
VERBOSE: Performing the operation "Invoke-ManageSolrCoreTask -Address https://blabla.bla.com:8984/solr -Action Create" on target "https://blabla.bla.com:8984/solr".
[CreateCores [1]]:[SolrCore] Performing Create on https://blabla.bla.com:8984/solr

VERBOSE: Updating Solr: Uri => 'https://blabla.bla.com:8984/solr/admin/cores?action=Create&Name=sc_pprd_xdb&wt=json'
VERBOSE: GET https://blabla.bla.com:8984/solr/admin/cores?action=Create&Name=sc_pprd_xdb&wt=json with 0-byte payload
Install-SitecoreConfiguration : Missing required parameter: name
At C:\Sitecore\installer\config\solr_instal_pprd.ps1:10 char:1
+ Install-SitecoreConfiguration @solrParams -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:15
Invoke-ManageSolrCoreTask : Missing required parameter: name
At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.0.0\Public\Install-SitecoreConfiguration.ps1:641 char:25
+                         & $entry.Task.Command @paramSet | Out-Default
+                         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Invoke-ManageSolrCoreTask

I must say that for the moment no link is set between the SOLR server and the SQL server. I can't understand why and where I should add an argument name.

  • can you open in browser : blabla.bla.com:8984/solr? is it secured connection ? I am not sure if Solr 6.6.4 is compatible with 9.0.1. Recommended version is 6.6.2 kb.sitecore.net/articles/227897 Commented Dec 13, 2018 at 11:57
  • Yes I can open it in a browser and the connection is secure. I know it works with solr 6.6.4 and sc 9.0.1 as we already have an environment working with the same version of OS and apps. Commented Dec 13, 2018 at 12:42

4 Answers 4


Maybe you are facing a problem with the SitecoreInstallationFramework version?

Sitecore 9.0.X requires 1.2.1:

Install-Module -Name SitecoreInstallFramework -RequiredVersion 1.2.1

Sitecore.9.1.0 requires 2.0.0:

Install-Module -Name SitecoreInstallFramework -RequiredVersion 2.0.0

Sitecore.9.1.1 requires 2.1.0:

Install-Module -Name SitecoreInstallFramework -RequiredVersion 2.1.0

Sitecore.9.2.0 requires 2.1.0:

Install-Module -Name SitecoreInstallFramework -RequiredVersion 2.1.0

Sitecore.9.3.0 requires 2.2.0:

Install-Module -Name SitecoreInstallFramework -RequiredVersion 2.2.0

Sitecore.10.0.0 requires 2.3.0:

Install-Module -Name SitecoreInstallFramework -RequiredVersion 2.3.0
  • No I am using Sitecore 9.0.1 and I have used the exact same solr script on many different servers in the past. I am using SIF 1.2.1 and it's giving me that error now which it never did before.
    – vipergtsrz
    Commented Dec 13, 2018 at 13:23
  • I was wrong. I found out that I actually did have 2.0.0 SIF installed and when I uninstalled it and installed the 1.2.1 version it worked. Thanks for this answer DarkStaR
    – vipergtsrz
    Commented Dec 13, 2018 at 13:30
  • 2
    Switching to 1.2.1 is the quickest fix. Otherwise there are a few additional steps to run 9.0.x on SIF 2.0.0: sitecore.stackexchange.com/questions/15334/…
    – jrap
    Commented Dec 13, 2018 at 15:11
  • Thanks I removed the module then reinstalled the version 1.2.1 and everything is working fine. Commented Dec 13, 2018 at 15:29

Modify xconnect-solr.json and sitecore-solr.json

Find the CreateCores task in each file Change the Name attribute in Params > Action to lowercase name

Original Script

{ "Action": "Create", "Address": "[parameter('SolrUrl')]", "Arguments": { "Name": "[variable('Core.Name')]" } },

Updated Script

{ "Action": "Create", "Address": "[parameter('SolrUrl')]", "Arguments": { "name": "[variable('Core.Name')]" } },
  • 2
    Only answer that actually solved this error Commented Jun 18, 2019 at 12:09
  • 1
    Semi-related: If you see the same error during commerce installation, you can perform an equivalent change in SIF.Sitecore.Commerce.1.4.7\Configuration\Commerce\Solr\sitecore-commerce-solr.json Commented Jul 31, 2019 at 19:44

I just ran into this same issue and it's because of this line in the sitecore script

VERBOSE: Updating Solr: Uri => 'https://blabla.bla.com:8984/solr/admin/cores?action=Create&Name=sc_pprd_xdb&wt=json'

The problem is that the "Name" paramter in the URI they are executing has a capital "N". If you try to invoke that same URI in a browser with a lowercase "n" it works.

The problem I am facing now is how to run this script without that error happening. Is this something that Sitecore has to change in their SIF code?

  • Thanks to DarkStaR I found out that this error happens when you're using Sitecore 9.0.X and trying to run SIF version 2.0.0. You need to install version 1.2.1.
    – vipergtsrz
    Commented Dec 13, 2018 at 13:31
  • Thanks for pointing that out :) It was "just" as simple as that Commented Dec 13, 2018 at 15:28

I came across the same error today and on investigation found another issue as the root cause. Logging it here for if someone else faces the same issue.

The root cause was SOLR was running out of the JVM. The same can be validated by browsing the SOLR URI. A message of the error is displayed there. Same can also be found in the logs of SOLR.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.