1

I am unable to start the xconnect related services Sitecore XConnect Search Indexer, Sitecore Processing Service and Sitecore Marketing Automation Engine after xconnect upgrade. Getting an error from event viewer while starting Sitecore XConnect Search Indexer is :

Application: XConnectSearchIndexer.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.NotSupportedException

Exception Info: System.IO.FileLoadException at System.Reflection.RuntimeAssembly._nLoad(System.Reflection.AssemblyName, System.String, System.Security.Policy.Evidence, System.Reflection.RuntimeAssembly, System.Threading.StackCrawlMark ByRef, IntPtr, Boolean, Boolean, Boolean) at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(System.Reflection.AssemblyName, System.Security.Policy.Evidence, System.Reflection.RuntimeAssembly, System.Threading.StackCrawlMark ByRef, IntPtr, Boolean, Boolean, Boolean) at System.Reflection.Assembly.Load(System.Reflection.AssemblyName) at Serilog.Settings.Configuration.ConfigurationReader.LoadConfigurationAssemblies() at Serilog.Settings.Configuration.ConfigurationReader..ctor(Microsoft.Extensions.Configuration.IConfigurationSection, Microsoft.Extensions.DependencyModel.DependencyContext) at Serilog.ConfigurationLoggerConfigurationExtensions.ConfigurationSection(Serilog.Configuration.LoggerSettingsConfiguration, Microsoft.Extensions.Configuration.IConfigurationSection, Microsoft.Extensions.DependencyModel.DependencyContext) at Sitecore.XConnect.Logging.Serilog.LoggerConfigurationExtensions.RegisterLoggerFromConfiguration(Microsoft.Extensions.Configuration.IConfiguration) at Sitecore.XConnect.Search.Indexer.Logging.Start(Microsoft.Extensions.Configuration.IConfiguration, System.String) at Sitecore.XConnect.Search.Indexer.Program.InitializeConfigurationAndRun(System.Action) at Sitecore.XConnect.Search.Indexer.Program.Main(System.String[])

Any advices?

  • which SOLR version do you have? – Sitecore Sam Dec 21 '18 at 16:02
  • 1
    This might be a .Net compatibility issue. Correct version should be .Net 4.6.2 or 4.7 - please see compatibility table here: kb.sitecore.net/articles/087164 You could also try repairing .Net framework and see if that helps. Best Regards. – Justin Bradley Dec 24 '18 at 18:41
  • @Sitecore Sam : Solr 7.2.1 – Sarath Raj Dec 26 '18 at 5:42
  • @JustinBradley: My machine already has 4.7 version – Sarath Raj Dec 27 '18 at 11:18
2

I had the same issue: System event viewer was only giving me the exact information you presented. I tried running maengine.exe manually and received a little bit more details of the error:

"Operation is not supported". An attempt was made to load an assembly from a network location ..."

I remembered when I had originally installed Sitecore 9.0.1 I had to add the following to the maengine.exe.config & XConnectSearchIndexer.exe.config files; which had been overwritten when I upgraded to 9.0.2. Adding the following line to the node in maengine.exe.config & XConnectSearchIndexer.exe.config resolved the issue for me:

<loadFromRemoteSources enabled="true" />

  • Thank you! This solved my issue even while I don't reminder needing this setting before. – dennisdegroot Apr 9 at 8:33
  • I did a little more investigation. Basically this is caused because the file is downloaded from the internet and I didn't unblock the files yet. From the docs: docs.microsoft.com/en-us/dotnet/framework/configure-apps/… If an application has been copied from the web, it is flagged by Windows as being a web application, even if it resides on the local computer. You can change that designation by changing its file properties, or you can use the <loadFromRemoteSources> – dennisdegroot Apr 9 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.