7

We have renderings which have compatible renderings configured. The button in the Experience Editor (Sitecore 8.1 Update-3) shows up on our local development environments and renderings can be replaced without problems. However on our testing environment, the button is gray (disabled). What could be the cause of this?

I searched for the command to look in the code what could be the cause of that. I see that it executes chrome:rendering:morph but I don't find a class which maps to this command. Anyone knows which command this is? It seems that something causes the command to be disabled.

  • 1
    Did you check Complatible Renderings field on the Rendering item and Allowed Controls on Placeholder settings? – Vlad Iobagiu Oct 19 '16 at 9:51
  • @SitecoreClimber You are completely right. We have changed the placeholder settings for that content type and these components are now not allowed anymore. Could you post this as the answer, then I can accept it? – Kevin Brechbühl Oct 19 '16 at 9:57
11

The replace button doesn't appear on Experience Editor in 2 cases :

  1. When rendering doesn't have any renderings or sublayouts in Complatible Renderings field.
  2. When Renderings or sublayouts are not in Allowed Controls of the Placeholder Settings.
0

Another gotcha is if the same Placeholder Key is defined more than once.

It appears that instead of merging allowed controls Sitecore will instead take the first one that it comes upon when iterating over the children of Placeholder Settings.

In our case we name our placeholder items the same as the key, so it was easy to find via search, but the field that stores the values is ID {7256BDAB-1FD2-49DD-B205-CB4873D2917C}.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.