2

How do I verify if the JSS server package is installed correctly in sitecore?

I have installed "JSS Server package -
Sitecore JavaScript Services Server for Sitecore 9.0 11.0.0 rev. 181031" by following the documentation: https://jss.sitecore.com/docs/getting-started/jss-server-install

As mentioned, when I browse the below url: http://<sitecore_host_name>/sitecore/api/layout/render/jss?item=/&sc_apikey=TEST, it responds with following resopnse

This page isn’t working. If the problem continues, contact the site owner. HTTP ERROR 400

Current Sitecore version - 9.0.2

Thanks

3

Although a little counter intuitive, this does seem like the expected response to verify the server components are installed correctly. The server should return a 400 with an invalid API key such as "TEST".

The documentation you linked to does actually state this, but can see why it's a little confusing.

Verify your server components install worked, by visiting http://your-sitecore-instance/sitecore/api/layout/render/jss?item=/&sc_apikey=TEST. You should receive HTTP Error 400.0 - API key is not valid if it is working correctly.

In Step two of the next section of the guide (App Deployment), there are instructions on how to set up an API key. https://jss.sitecore.com/docs/getting-started/app-deployment

  • Thank you for the answer. I was expecting "API key is not valid" in the response. However after following the step two as you have mentioned above, I got the desired response. – Hashmat Ali Jan 9 at 8:37

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.