3

I have Sitecore 9.1 instance with SXA 1.8 and Solr. I am new to Solr but its service and admin site seem to be running ok. However there are a lot of errors in the log of Solr.

40620 2019:01:11 11:17:18 ERROR Solr Error : ["undefined field local"] - 
Query attempted: [((local:("\/Data\/Text 3") AND _path: 
(dc00ec1b9747438dbf45fd9e7b4cca70)) AND _language:(en))]

The same error repeated for many paths and queries but "undefined field local" is consistent.

Posts seem to mention having an error config somewhere but I'm not sure what to be looking for and where.

I am using Solr 7.2.1 and I added master and web cores for sxa with names matching the config file, populated the solr managed schema and rebuilt in sitecore. SXA Web is showing as Optimised and Current (green ticks) but SXA Master is Current but not Optimised.

Rebuilding SXA Master index generates those errors.

  • 1
    Hi Jen, have you configured the necessary Solr cores for SXA as per the installation guide, and which version of Solr are you using? – andyp Jan 15 at 6:00
  • Additional information added to the post. Thanks! – Jen Jan 15 at 21:46
  • 1
    I have the same error in an SXA 1.8 install. I'm also getting "copyField dest :'extension_t_pl_str' is not an explicit field and doesn't match a dynamicField" in an out of the box vanilla SXA install. Web index is ok, only Master is throwing errors. Both of these look like bugs. – andyp Jan 15 at 22:52
0

Turns out this is a bug in SXA 1.8.

https://dev.sitecore.net/Downloads/Sitecore%20Experience%20Accelerator/18/Sitecore%20Experience%20Accelerator%20181/Release%20Notes

enter image description here

It is fixed in Sitecore 9.1.1 and SXA 1.8.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.