6

Mixing Sitecore and PHP has worked for all versions up till 9.1. Now PHP pages render fine, but when you post to a page, the $_POST collection is empty now.

I took a vanilla Sitecore 9.1 instance and ripped it apart until it was basically an MVC site again. Once I got it that far, it worked again. I have disabled all the modules and handlers in the web.config working my way through configs now. I have to imagine it is a httpRequestBegin or a pipeline.

Just looking for any thoughts on diagnosing this. I have disabled my test page with the IgnoreUrlPrefixes, but Sitecore is still clearing the post variables.

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:x="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <settings>
      <setting name="IgnoreUrlPrefixes">
        <patch:attribute name="value">/cauer.php</patch:attribute>
      </setting>
    </settings>
  </sitecore>
</configuration>

Update:

I added a debugging processor at the beginning and end of httpRequestBegin and httpRequestEnd. In 8.2 U7 when my php file is in the IgnoreUrlPrefixes I get a hit at the beginning of the httpRequestBegin. But in 9.1 I do not get the hit. It is skipped. They seem to be handling the IgnoreUrlPrefixes urls differently in 9.1.

Update 2

This is reported as a bug. Being worked on now.

1

I reported this as an issue when I created this question. Support worked through it and created a patch for it. It was a complete replace of the Sitecore.Owin.Authentication.IdentityServer.dll

Reference support ID 305761 for the fix.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.