I am trying to follow the instructions for setting up the HelixBase solution, using these instructions. https://github.com/muso31/Helixbase

Unfortunately on step 5 I'm a bit lost.

What do I need to do to run Unicorn?

To confirm what I have tried - I have restored nuget packages, built the solution and used the publish all projects gulp task. I have tried logging into sitecore admin and then changing the url to http://demo.helixbase.sc/unicorn.aspx

enter image description here

  • 2
    I'm unfamiliar with the HelixBase project and which version of Unicorn it uses. However we recently released some fixes for Unicorn and Sitecore 9.0x/9.1 - try updating your Unicorn package to version 4.0.7
    – Mark Cassidy
    Jan 18, 2019 at 8:42

2 Answers 2


Sitecore 9.1 uses identity server for authorization. muso31/Helixbase uses unicorn 4.0.4 and old version of Rainbow.

Just update Unicorn to 4.0.7 version and Rainbow to 2.0.5. There are some changes in unicorn config files for new version. Be sure to update them https://github.com/SitecoreUnicorn/Unicorn/tree/master/src/Unicorn/Standard%20Config%20Files

  • In terms of the config changes. Do I need to add the Unicorn.UI.IdentityServer.config file if I'm using Sitecore 9.1 locally? helixbase is throwing a different error whether I have this file or disable it. Is that the only config change that is required for these new versions? Or did I miss reading a summary type page that explicitly said what had changed in 9.1. Thanks!
    – Jen
    Jan 21, 2019 at 1:01
  • 1
    Ok so it helps that I restart IIS and have that confi enabled. I am now getting an error: Cannot activate Unicorn.Deserialization.UnicornDeserializer, constructor param 'ignoreBranchId' (Boolean). The type 'Boolean' is probably not registered, or may need to be an explicit unmapped parameter (as an XML attribute on the type registration). Inner message: Cannot construct System.Boolean because it has no constructor!
    – Jen
    Jan 21, 2019 at 1:17
  • 2
    New version of UnicornDeserializer (4.0.7) has constructor parameter ignoreBranchId. You can see it here github.com/SitecoreUnicorn/Unicorn/blob/master/src/Unicorn/… Be sure that you updated your config. <deserializer type="Unicorn.Deserialization.UnicornDeserializer, Unicorn" ignoreBranchId="true" singleInstance="true" />
    – x3mxray
    Jan 23, 2019 at 10:25

As has been mentioned, updating to 4.0.7 will resolve the issue, the reason you are seeing the Cannot construct System.Boolean because it has no constructor error is because you have not added all relevant Unicorn configs. I have now updated Helix Base to Unicorn 4.0.7 and if you pull the latest changes you can see the relevant configs updated in the App_Config/Include/Unicorn folder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.