2

During the process of upgrading to Sitecore 9.1, I configured Solr indexes, and they show up in dashboard but not showing up in Sitecore indexing manager. Any suggestions/advice?

The crawling log shows this warning: Log file contents

1
  • 1
    Do the indexes show up in the /sitecore/admin/showconfig.aspx config? Jan 21 '19 at 17:34
2

So, the reason why the solr cores didn't show up in sitecore indexing manager was there was a naming mismatch between the cores defined in sitecore config vs the cores in Solr Dashboard. We added a solrsetting patch config to provide the accurate names for the cores to resolve the issue.

1

This can happen if Sitecore can't connect to Solr. Verify that Solr is functional, and connectivity is functional between the Sitecore server and the Solr server.

Also ensure that you have followed the appropriate setup instructions for your version of Sitecore (9.1 linked below):

Walkthrough: Setting up Solr (Sitecore 9.1)

0

Me too had same issue.I was make sure everthing in place such as Solr connectivity, proper Index names. But in my case I did below solution to fix the issue.

Below configuration caused the issue in my case: (notice the forward slash at end)

<add name="solr.search" connectionString="https://<solr server domain URL>:8983/solr/" />

Solution:

After removed the forward slash at the end of URL, working like champ.

<add name="solr.search" connectionString="https://index-lablink.ttgtpmg.net:8983/solr" />
0

I have faced the same issue that no indexes are shown in the Sitecore indexing manager. I verified the Solr console and all the cores were loading fine there. I have identified after some time that ContentSearch.Enabled was set to false in Sitecore.ContentSearch.config . Changed this setting to true and tried connecting the indexes. it started coming.

Basically, Just go to this path, <cm_root>\App_Config\Sitecore\ContentSearch\Sitecore.ContentSearch.config and search this setting and make sure this is true.

<setting name="ContentSearch.Enabled" value="true" />

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.