1

Solution builds just fine on local environment but the build server fails to locate Sitecore.NVelocity. Thoughts on why it is not found? The nuget.config file has an entry below:

<add key="Sitecore 9.1" value="https://sitecore.myget.org/F/sc-platform-9-1/api/v3/index.json" />

Error from DevOps is:

The nuget command failed with exit code(1) and error(Errors in packages.config projects
    Unable to find version '9.0.180604' of package 'Sitecore.NVelocity'.
      C:\Windows\ServiceProfiles\NetworkService\.nuget\packages\: Package 'Sitecore.NVelocity.9.0.180604' is not found on source 'C:\Windows\ServiceProfiles\NetworkService\.nuget\packages\'.
      https://www.nuget.org/api/v2/: Package 'Sitecore.NVelocity.9.0.180604' is not found on source 'https://www.nuget.org/api/v2/'.
      https://sitecore.myget.org/F/sc-platform-9-1/api/v3/index.json: Package 'Sitecore.NVelocity.9.0.180604' is not found on source 'https://sitecore.myget.org/F/sc-platform-9-1/api/v3/index.json'.)
Packages failed to restore
1

You need to update your Sitecore.NVelocity to version 9.0. There is no version 9.0.180604 on the Sitecore 9.1 feed. It works local because you have a copy of the old dll somewhere in your packages or bin folder.

Remember that the Sitecore 9.1 feed ONLY has Sitecore 9.1 release dlls. It does not contain any old Sitecore dlls like the old feed used. It just contains 1 single release.

Here is the version in the 9.1 feed.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.