0

I have Sitecore 9.0 update -1 version and followed (https://jss.sitecore.com/docs/getting-started/jss-server-install) to setup JSS server.

I cant able to deploy the app while running deploy command, i got below error in attached screen shot.

enter image description here

Below my scjssconfig.json

{
  "sitecore": {
    "instancePath": "D:\\SC9\\sc90.local",
    "apiKey": "{781AA908-F82E-4122-87E7-AB4D60B76760}",
    "deploySecret": "eugskd8mophj3sq861yqybtttf3p5yctzxlu6rgk7m",
    "deployUrl": "http://sc90.local/sitecore/api/jss/import",
    "layoutServiceHost": "http://sc90.local",
    "deploymentSecret":"eugskd8mophj3sq861yqybtttf3p5yctzxlu6rgk7m"
  }
}

Also i can see manifest.zip file in my local but seems import process fails.

How should i troubleshoot further here,

enter image description here

0

Upgrading jss server package solved my issues.

Based on this article "https://isaadansari.wordpress.com/2018/09/02/troubleshooting-with-sitecore-jss-deployment-problems/"

My Jss-cli version(11.0) and react application versions are latest but my Jss server tech preview version is 2. So i downloaded tech preview version 4 and installed.

enter image description here

Now its worked.

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.