0

I'm able to create modules and duplicate renderings without any problems when on my local Sitecore 9.1 / SXA 1.8 build, but whenever I am facing issues when trying to do the same process when using sites deployed to Azure (I mention this detail because it's the only difference I can think of between the two).

Here's the video I follow along with to achieve this process: https://www.youtube.com/watch?v=PEYJxitzNLg&

I initially tried duplicating the promo rendering on a Sitecore 8.2 / SXA 1.7.1 instance, and noticed that the following folder was empty.

Templates > Branches > Feature > ModuleName

The following folder is also missing "Add Available Renderings" and a "Rendering Variants" folder

System > Settings > Feature > ModuleName > ModuleName Site Setup

Everything else seems to have duplicated correctly.

I tried restarting IIS / clearing the Sitecore cache but the issue still occurred.


I decided the above issue was probably due to us using an older build of Sitecore and SXA, and because it wasn't a fresh install, there may be some underlying issues. So today we install a brand new, fresh 9.1 / SXA 1.8 install which sits on Azure.

The exact issue persists, I've deleted the module and component and restarted from scratch, but I get the same results.

To ensure I was doing it correctly, straight after that I completed the exact same process on my local 9.1 / SXA 1.8 instance, and that worked perfectly, everything duplicated as expected.

I have no idea where to look in this situation, if anybody could share any information at all it would be hugely appreciated.

Thank you in advance,

Jack

  • 1
    I found with 1.8 that I have to add my own Rendering Variants folder - but the Add Available Renderings was being added as expected. This is just locally and not on Azure. – Jen Feb 5 at 23:26
0

Having contacted Sitecore support it seems that there is a bug when creating an SXA 1.8 instance on Azure, it does not include all of the necessary items for the Master database.

The workaround to this problem is to install Sitecore 9.1 and then to manually install Powershell 4.7.2 (or 5.0) and SXA 1.8

To track the future status of this bug report, please use the reference number 308512. More information about public reference numbers can be found here: https://kb.sitecore.net/articles/853187

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.