3

Sitecore 9.1 is already installed on the computer. SitecoreInstallFramework 1.2.1 and 2.0.0 are also installed. I am trying to use SIF 1.2.1 version in order to install Sitecore 9 update 2. I am executing below command:

Import-Module -Name SitecoreInstallFramework -Force -RequiredVersion 1.2.1

I am getting below error:

Import-Module : The following error occurred while loading the extended type data file: Error in TypeData "System.Object": The member HasMemberPath is already present.
Error in TypeData "System.Object": The member HasMemberValue is already present.
Error in TypeData "System.Object": The member ExtendWith is already present.
Error in TypeData "System.Object": The member HasMember is already present.
Error in TypeData "System.Object": The member GetMember is already present.
Error in TypeData "System.Object": The member GetMembers is already present.
Error in TypeData "System.Object": The member GetMemberNames is already present.
At line:1 char:1
+ Import-Module -Name SitecoreInstallFramework -Force -RequiredVersion  ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [Import-Module], RuntimeException
    + FullyQualifiedErrorId : FormatXmlUpdateException,Microsoft.PowerShell.Commands.ImportModuleCommand

Any inputs?

6

I am able to resolve this issue by following below steps:

1.) Uninstall SIF 1.2.1

Uninstall-Module -Name SitecoreInstallFramework -RequiredVersion 1.2.1

2.) Install SIF 1.2.1 Again

Install-Module -Name SitecoreInstallFramework -RequiredVersion 1.2.1

3.) Running a specific version of SIF (1.2.1) to install sitecore 9 update 2. You may have to close powershell and then reopen powershell before running below script:

Import-Module -Name SitecoreInstallFramework -Force -RequiredVersion 1.2.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.