1

Hi I am installing sitecore 9.1 with SIF and i am using solr 7.2.1 version.

installation fails due to below error.

Below my error in powershell:

[-------------------------------------------------- XConnectSolr_CreateCores [1] : ManageSolrCore ----------------------------------------------------------------] [XConnectSolr_CreateCores [1]]:[Requesting] https://localhost:8984/solr/ [XConnectSolr_CreateCores [1]]:[SolrCore] Performing Create on https://localhost:8984/solr/

[ERROR] Install-SitecoreConfiguration : NotFound - https://localhost:8984/solr//admin/cores?action=Create&name=sc910_xdb&property.update.autoCreateFields=false&wt=json [ERROR] At C:\resourcefiles\new resource files\XP0-SingleDeveloper.ps1:93 char:1 [ERROR] + Install-SitecoreConfiguration @singleDeveloperParams *>&1 | Tee-Objec ... [ERROR] +

+ CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException [ERROR]     + FullyQualifiedErrorId :
Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration
[ERROR]   [TIME] 00:00:35

How to proceed from here?

Below Solr logs: [but no clue]

2019-01-31 14:26:57.135 INFO (main) [ ] o.e.j.s.Server jetty-9.3.20.v20170531 2019-01-31 14:26:57.923 INFO (main) [ ] o.a.s.s.SolrDispatchFilter _ _ Welcome to Apache Solr™ version 7.2.1 2019-01-31 14:26:57.924 INFO (main) [ ] o.a.s.s.SolrDispatchFilter / __| | | _ Starting in standalone mode on port 8984 2019-01-31 14:26:57.924 INFO (main) [ ] o.a.s.s.SolrDispatchFilter __ / _ \ | '| Install dir: C:\solr-7.2.1\solr-7.2.1 2019-01-31 14:26:57.937 INFO (main) [ ] o.a.s.s.SolrDispatchFilter |/_/|| Start time: 2019-01-31T14:26:57.925Z 2019-01-31 14:26:57.955 INFO (main) [ ] o.a.s.c.SolrResourceLoader Using system property solr.solr.home: C:\solr-7.2.1\solr-7.2.1\server\solr 2019-01-31 14:26:57.962 INFO (main) [ ] o.a.s.c.SolrXmlConfig Loading container configuration from C:\solr-7.2.1\solr-7.2.1\server\solr\solr.xml 2019-01-31 14:26:58.558 INFO (main) [ ] o.a.s.c.CorePropertiesLocator Found 0 core definitions underneath C:\solr-7.2.1\solr-7.2.1\server\solr 2019-01-31 14:26:59.184 INFO (main) [ ] o.e.j.s.Server Started @2696ms 2019-01-31 14:42:02.883 INFO (Thread-0) [ ] o.a.s.c.CoreContainer Shutting down CoreContainer instance=2036127838 2019-01-31 14:42:02.883 INFO (Thread-0) [ ] o.a.s.m.SolrMetricManager Closing metric reporters for registry=solr.node, tag=null 2019-01-31 14:42:02.883 INFO (Thread-0) [ ] o.a.s.m.SolrMetricManager Closing metric reporters for registry=solr.jvm, tag=null 2019-01-31 14:42:02.883 INFO (Thread-0) [ ] o.a.s.m.SolrMetricManager Closing metric reporters for registry=solr.jetty, tag=null 2019-01-31 14:42:02.884 INFO (Thread-0) [ ] o.a.s.c.TransientSolrCoreCacheDefault Allocating transient cache for 2147483647 transient cores

  • 2
    Couple things to check/try.1.) Errors you get when you go to localhost:8984/solr. 2.) Check for any process listening on port 443 using the following command. netstat -aon | find /i ":443". You will need to temporarily stop the process. 3.) Try a different port. – RReilley Jan 31 at 21:32
  • 1
    The other thing I would check is to make sure that the SolrRoot parameter is correct. The default is C:\solr-7.2.1. – Mikeyp Feb 1 at 14:54
5

looking at the url for the solr in the error description it seem like there is a "/ " to much - https://localhost:8984/solr//admin

ensure your parameter in the powershell doesn’t contain a traling '/'

should be something like $SolrUrl = "https://localhost:8984/solr"

  • This worked. You should remove trailing '/' – Siva Kumar Feb 25 at 4:58
  • It worked for me as well – Ashish Bansal Mar 7 at 17:44
3

I had the same issue few days ago and it was only the Solr server URL.

https://localhost:8984

Make sure it is really localhost (that was my error, my script was creating the server at https://solr:xxxx) and that your port is correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.